2

Today I noticed that all answers from Sandbox were moved to archive again.

I don’t know the actual reason why they were moved, but some of my bug reports have links to sandbox’s posts/comments, and now such links are broken.

Is it possible to automatically fix such links as it was made while migrating from http to https or simply redirect to archived item?

5

Posts in the sandbox are subject to delete or archiving at any time...

...you don't usually build sand castles for posterity, eh?

Buuuut, you can keep these links working if you want: just use short URLs. Like, /q/[id] or /a/[id] - those will continue working even if the answer is later moved.

  • Looks like the link to comment is not working if I use /a/[id] format. – αλεχολυτ Oct 8 '17 at 6:15
  • @alexolut comments really should not be used in bug reports, they are temporary to begin with, even without sandbox. – Shadow Wizard Oct 8 '17 at 11:51
  • @ShaWizDowArd but, but... but my report is about comment :) – αλεχολυτ Oct 8 '17 at 12:32
  • @alexolut oh. Well, screenshot should be enough. – Shadow Wizard Oct 8 '17 at 12:36
  • 1
    @alexolut that said, URL like https://meta.stackexchange.com/posts/comments/[id] might still work, e.g. meta.stackexchange.com/posts/comments/981370 – Shadow Wizard Oct 8 '17 at 12:38
  • @alex... Just post comments on your actual bug report. Even if the sandbox wasn't getting archived, clicking through is super annoying. – Shog9 Oct 8 '17 at 19:43
  • You're right. I just made an experiment in the sandbox first, and then I created a bug-report with links. – αλεχολυτ Oct 8 '17 at 20:56
  • build sand castles for posterity or prosperity? – Meta Bug Wizard Sep 21 '18 at 15:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .