8

I was visiting some transcripts from a chat room and then I found a link to another room which was removed. On that custom error page, I found two main issues and one was caused by another main issue.

This issue can be found in the custom error page shown, because the room is either deleted or not existed at all.

Issues

1. The topbar overlays the Object moved to here message whereas here is a link, but it needs much effort to click on because of the topbar.

enter image description here

2. The dropdowns are not loading.

Once clicked, it shows the div and pretend like loading but then suddenly went and hide.

Enter image description here

Blame http

When I checked the console, it shows an issue that it makes a request to http://chat.site and it presents Access control allow origin is not present in that resource.

On Stack Overflow

Enter image description here

On chat meta Stack Exchange

Enter image description here

1 Answer 1

2

Something was wrong in the HTTPS redirect code that cause some HTTP URLs to not be correctly shuffled over to HTTPS. ¯\_(ツ)_/¯

This has been fixed.

6
  • But the links are still being created as HTTP?
    – Catija
    Feb 28, 2018 at 23:55
  • @Catija Shouldn’t be. Are they?
    – Adam Lear StaffMod
    Feb 28, 2018 at 23:56
  • Yep. I have a report here that talks about it... both user-created and mod-created links to chat rooms are still serving up HTTP links. meta.stackexchange.com/questions/306915/…. This one was just created today: interpersonal.stackexchange.com/questions/11165/…
    – Catija
    Feb 28, 2018 at 23:57
  • @Catija No, are new links (say, after about 4pm NYC time today) being generated as http? :)
    – Adam Lear StaffMod
    Mar 1, 2018 at 0:20
  • Ah! Hmmmm... I don't know! Let me go make one and see. :P
    – Catija
    Mar 1, 2018 at 0:22
  • They are :D YAY! I guess this solves my problem, too.
    – Catija
    Mar 1, 2018 at 0:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .