5

This question got locked. The label below the question reads

This question's answers are a collaborative effort: if you see something that can be improved, just edit the answer to improve it! No additional answers can be added here

I tried to edit an answer, which returned the error message

Question is locked

Is this contradictory behaviour on purpose? If so, how does this make any sense? If no, does anybody know what causes this?

screenshot highlighting the problem

  • Did you try to edit the question, rather than an answer? – Servy Oct 26 '17 at 14:43
  • no. i tried editing an answer. screenshot follows shortly – Lonely Neuron Oct 26 '17 at 14:44
  • 2
    Possible duplicate of Always show the edit button on questions – gnat Oct 26 '17 at 14:50
  • 3
    Apparently you need edit permissions to edit wiki-locked posts, and edits cannot be suggested. – Servy Oct 26 '17 at 14:52
  • 1
    @gnat how is this possibly a duplicate of the question you linked? they are so different in kind i can't imagine why anyone would raise this flag! – Lonely Neuron Oct 26 '17 at 14:55
  • @Servy in that case the label encouraging me to edit any answer should not be shown upon clicking edit, right? – Lonely Neuron Oct 26 '17 at 14:57
  • Is this a general question or did you want to make an edit there? – Jon Clements Oct 26 '17 at 15:17
  • 2
    This is not a duplicate of Always show the edit button on questions, but it would be a duplicate of this question (on MSO). – Laurel Oct 26 '17 at 15:24
  • @JonClements I wanted to edit another answer from the same question, but it was too long to fit nicely on a screenshot so i chose another answer – Lonely Neuron Oct 26 '17 at 15:26
  • @Laurel yes, indeed. It is! – Lonely Neuron Oct 26 '17 at 15:26
5

As I wrote over yonder,

That lock reason is supposed to be used for questions with just a few community-wiki answers - in other words, answers that anyone with a nominal amount of rep can edit without needing approval. Stuff like this, where the answer is a collaborative effort built by many editors over the years.

That's still true. In order to edit an answer to a locked question, you need to have editing privileges; you can't suggest edits to answers of locked questions. The majority of questions locked for this reason are also community wiki, so this is why you don't see this often.

In this case, there actually is a fair bit of collaborative editing on the top questions, and given its frequent use as a duplicate target, I think there's a lot of value to be had in encouraging more edits - so I've taken the unusual action of converting the entire lot to CW.

That still doesn't allow suggested edits, mind you - but it does allow nearly anyone with some trivial experience on the site to contribute edits directly. Provided that isn't abused, it should suffice.

4

After a few more reports of this causing confusion we decided to fix it.

You shouldn't get this error any more.

We talked about it internally and Shog did some digging and we can't really figure out why suggested edits on answers to locked questions were ever prevented (it's been this way since 2011!) so we've changed the settings so that suggested edits are allowed!

Thanks for bringing this to our attention!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .