8

When using Chrome 62.0.3202.94 (Official Build) (64-bit) on Windows 10 Pro Fall Creators Update, I get a scroll on some of the posts in the real-time tab of stackexchange.com.

Also tested Firefox 57.0 (64-bit), Edge 41.16299.15.0 and IE11, and no scroll appear on those.

enter image description here

  • This got totally nothing to do with any of the sites, stackexchange.com got its own source code and its own design. – Shadow The Princess Wizard Nov 30 '17 at 15:42
  • @ShadowWizard Okay... will remember that :) – LGSon Nov 30 '17 at 15:44
  • No repro with same browser, maybe you installed some userscript long ago, forgot about it, and now it's messing with the design. – Shadow The Princess Wizard Nov 30 '17 at 15:44
  • Wait... I'm able to reproduce this when zooming. Since there is no zoom in your case (as screenshot proves), maybe you got some global zoom feature in your Windows? (or large font) – Shadow The Princess Wizard Nov 30 '17 at 15:46
  • 1
    @ShadowWizard Correct. I do have the Windows default, which increase content/text to 125% – LGSon Nov 30 '17 at 15:48
  • 1
    Try changing to 100% and if this "solve" this case please post self answer explaining what happened. I'm not sure if it's considered bug or not in this case (since SE does not support zooming), but at least the team will have the full details if and when going to fix/change it. – Shadow The Princess Wizard Nov 30 '17 at 15:50
  • @ShadowWizard Done – LGSon Nov 30 '17 at 15:58
5

Based on a dialog with Shadow Wizard, it appears this only occurs when the page is zoomed.

As I don't zoom my pages, I overlooked that Windows actually does, where it has a display setting one can change the size of text, apps and other items.

With this set to 125%, which mine were, it create the same effect page zoom does, hence some posts get a scrollbar.


Update based on a comment

The .question-container element has its overflow set to auto, and by that is allowed to render a scrollbar if necessary, which it obviously does in some situations.

If one change it, to e.g. overflow: hidden, it goes away.

  • So is this actually a browser bug, or HTML layout problem? – Vlad Jan 5 '18 at 9:41
  • @Vlad It could be both, where either Chrome has a bug, or they (Chrome devs.) have interpret a certain spec. different then the rest of the browser manufacturers. To know one need to inspect the actual code and check why it render the scrollbar, and that is for SE's team to do. – LGSon Jan 5 '18 at 12:50
  • @Vlad The overflow is set to auto on the post's outer element, hence allow the scrollbar to render, which it obviously does in some situations. Changing it to e.g. hidden and it goes away. – LGSon Jan 5 '18 at 12:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .