We just noticed on the Tavern on the Meta, that hats seem to have vanished on chat.

They also seem to be gone on regular chat, and I don't see the snowflake on Meta Stack Exchange some of the time (it's randomly appearing by the looks of things then vanishing).

I usually use Vivaldi, but the same issue on Firefox (I'm on 57 or thereabouts).

I suppose we can blame load, or hats..

or is it a hat hating grinch?

enter image description here

Totally glitched grinched I guess

  • can't repro now :) Commented Dec 13, 2017 at 8:59
  • I'm seeing this too. But I wasn't 3 hours ago when you posted this ... Commented Dec 13, 2017 at 12:30
  • Oh just edited in the panda. I'm not even chasing hats! Commented Dec 13, 2017 at 12:31
  • 1
    You should have waited 4 minutes to post this question ;-) Commented Dec 13, 2017 at 12:32

1 Answer 1


Right now, requests to winterbash2017.stackexchange.com and to cdn-prom.sstatic.net go to the same place, which is not meant to be the case (the latter domain, which holds the static files like JavaScript and hat images, is meant to be served from the CDN, as the name indicates).

I think all those requests may have overwhelmed our trusty Winter Bash servers in one way or the other. I have disabled hats for anonymous visitors on Stack Overflow to cut down the traffic a couple of hours ago, and everything seems to have been fine since. I'll enable it again once the CDN configuration is correct, and monitor further.

If somebody was seeing issues very recently (at the time that I write this answer), that was something different -- the first attempt at fixing the CDN config was more of a Verschlimmbesserung (and was quickly reverted, but since it involved a DNS change, you might still see some blips).

Update: Should be all good now.

  • Note for anyone else still having a problem - I was about to report I still had problems but a Ctrl-F5 to force a cache update fixed it.
    – PeterJ
    Commented Dec 13, 2017 at 12:58
  • I have this issue across the network on IE11. No snowflake, no hats. If I go to firefox the snowflake is there, so are the hats. I've tried on three computers now (two at work, one at home) and all show the same. Commented Dec 16, 2017 at 9:40
  • @TomCarpenter Winter Bash doesn't work in IE.
    – balpha StaffMod
    Commented Dec 16, 2017 at 9:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .