1

I occasionally need to visit SE sites on an older web browser. Normally, this isn't a problem, but during Winterbash, the scripts loading and drawing the hats slow things down so much that it takes several minutes for the page to reach a point where I can do things like "scroll" or "click on links", and having an SE page load in a background tab slows down all SE tabs.

Is it possible for me to disable hats on just this one browser?

6
  • What browser? Adblock might work here Commented Dec 15, 2017 at 3:01
  • Opera 12 on Linux.
    – Mark
    Commented Dec 15, 2017 at 3:02
  • Oh. Presto Based opera. Didn't realise it was still a thing ._. . didn't it have a built in adblock of some sort? Commented Dec 15, 2017 at 3:29
  • 1
    Do you have any way to block content loaded from the cdn-prom.sstatic.net domain? I think that should work, but I don't know if your browser has any adblock or resourceblock feature that would allow that.
    – SPArcheon
    Commented Dec 15, 2017 at 8:23
  • "hate hats"? Do you mean "have hats"? Commented Dec 15, 2017 at 8:43
  • 1
    He wants to block hats on one browser that's old, unusual, and in this case, misbehaving... Commented Dec 15, 2017 at 8:59

2 Answers 2

6

Mild Dislike is possible

Building off what @SPArchaeologist said...

There's an opera-presto specific ways to do this - go to preferences, advanced, then content. Add "https://cdn-prom.sstatic.net" to the blocked content list and you won't see any hats or the snowflake.

![enter image description here

There's also a way to do site specific user agent masking under manage site preferences which might work too. Not tested that properly yet though it might be a better way. Since IE won't work this ought to convince the page not to load the hats. This should work per site.

enter image description here

2
  • Blocking cdn-prom should also get rid of the snowflake. Maybe Opera only blocks actual network requests, and as long as the file comes from cache, it still runs?
    – balpha StaffMod
    Commented Dec 15, 2017 at 10:42
  • 1
    Yeah, that worked when I retried.Probably caching Commented Dec 15, 2017 at 10:46
2

The "opt-out" setting seems to be stored server side on a per-user base, so there is no easy way you could achieve what you want. After all, even if you do access the site from two different browser on two different machines your user profile is still the same and so is any hat related configuration you made.

You could still try some workarounds in order to stop the Winter Bash script being loaded in your browser. I don't know a lot about Opera 12 on linux, but two main options come to mind:

  • try and block content from the domain "cdn-prom.sstatic.net" either using an origin based resource filter (something like uMatrix on Chrome) or some of your browser built-in features (if available). As a reference I use Firefox and if I configure NoScript to block script from cdn-prom.sstatic.net hat disappears completely on meta (I think that would also apply to chat).

  • hats aren't supported on Internet Explorer. While you can't really switch your browser, maybe you can trick the servers into believing you are using IE. Again, I don't know how they implemented the "No Hats for IE" feature, but maybe it would be worth trying to switch your browser user agent string to one used by Internet Explorer (warning: this could potentially break the rest of the page if they are using IE specific fixes)

I think those are the only available options. I think your best bet is still blocking the "cdn-prom.sstatic.net" domain.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .