3

It's been a while since I last used the Data Explorer, although any query I try now comes up with nothing, for example:

How many upvotes do I have for each tag?

I'm trying to query data from stackoverflow.com. Is there something wrong with it?


EDIT: Apparently the Switch sites option at the bottom of the query page was doing the opposite of what I thought:

enter image description here

I had mistakenly assumed the site which I was querying was stackoverflow because of the icon that was currently showing — it was actually the site it would switch to upon clicking it. As a suggestion, if there was an indicator of which site was currently set to query upon a quick glance of the page it would be helpful and perhaps avoid similar confusion by others.

4

The link you are using sets the query to be run on Meta Stack Overflow:

http://data.stackexchange.com/meta.stackoverflow/query/785/how-many-upvotes-do-i-have-for-each-tag
                              ^^^^^^^^^^^^^^^^^^

You need to either switch the site to Stack Overflow in the UI, or use a link that goes directly to a Stack Overflow query before running it. (Or whatever site you're trying to run it on.)

http://data.stackexchange.com/stackoverflow/query/785/how-many-upvotes-do-i-have-for-each-tag
                              ^^^^^^^^^^^^^
  • Thanks for the clarification, one question though - does the Switch sites option at the bottom not do what you described? – l'L'l Dec 22 '17 at 1:43
  • @ILI It does. You can click the site icon itself to flip back and forth between main and meta, and it will change the URL each time you do that too. – animuson Dec 22 '17 at 1:45
  • That's the thing, when I try that I still get no results... – l'L'l Dec 22 '17 at 1:47
  • It returns results for me when I try. Did you re-run the query after switching? Are you using the correct user ID number? – animuson Dec 22 '17 at 1:59
  • Aha! I see what happened... I was looking at the icon thinking that was the site that is currently set to query, when in reality that's the site it's indicating it will switch to. thanks again — problem solved. cheers! – l'L'l Dec 22 '17 at 2:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .