11

I create a query using [Post Link] and [Comment Link] and I noticed that the generated links are inverted for some sites, for example:

This http://data.stackexchange.com/ptme/query/775699/bug-in-links (query to pt.stackoverflow meta) generate links like this:

https://meta.pt.stackoverflow.com/q/1

But the correct one is:

https://pt.meta.stackoverflow.com/q/1

Ths http://data.stackexchange.com/esme/query/775699/bug-in-links (query to es.stackoverflow meta) generate links like this:

https://meta.es.stackoverflow.com/q/146

But the correct one is:

https://es.meta.stackoverflow.com/q/146

others like Web Apps Meta and Game Dev Meta and Russian Stack Overflow are generating correctly:

including the bug that occurred in Arqade Meta (mentioned in Per-site metas are not linked properly from the Data Explorer) has already been fixed, then it is a problem that only occurs in some cases, test arqade meta:

  • @ShadowtheHedgehogWizard is not dup, bug fixed to "Arcade Meta", see this: data.stackexchange.com/meta.gaming/query/775699/bug-in-links work fine. The bug now is other sites. – Guilherme Nascimento Dec 28 '17 at 21:02
  • @ShadowtheHedgehogWizard that's a bug specific to some multi-site queries, where links are generated by specific SQL statements. This bug is specific to Magic Links which are generated by SEDE's JavaScript libraries (IIRC). – Glorfindel Dec 28 '17 at 21:02
  • If anything it might be related or a duplicate of this one meta.stackexchange.com/questions/281562/… – rene Dec 28 '17 at 21:06
  • @Glorfindel oh, OK, Close vote retracted, comment deleted. – ShaWiz Dec 28 '17 at 21:08
  • @Glorfindel [Comment Link] the same problem occurs :/ (may occur with all "link aliases") – Guilherme Nascimento Dec 28 '17 at 21:57
  • 1
    The Sites table inside the Data.stackexchange database needs to be updated with a new value for the url column. This update query at the end is my best guess but it needs Nick to verify and execute as the production data might have more/other variations I didn't cater for. – rene Dec 28 '17 at 22:55
  • @rene I'm going to test all the sites that I can and I'll confirm if there was any missing, thanks for the feedback. – Guilherme Nascimento Dec 29 '17 at 0:26
  • @GuilhermeNascimentoP. well, that would be a waste of your time I think. If it is like this you'll have to check 160 meta sites. I'll try to nudge a dev in chat to have a look and ask if we can offer any help. – rene Dec 29 '17 at 9:29
  • @rene you're right. Thanks! – Guilherme Nascimento Dec 29 '17 at 12:15

You must log in to answer this question.

Browse other questions tagged .