8

I'm trying to create an Atom feed that can be added to chat. To do so, I've followed the format used by https://stackoverflow.com/feeds - I've excluded the re and creativeCommons XMLNS declarations since I don't need them, but otherwise my feed contains the same elements as the SO-provided feed.

However, when I add it to a chatroom, no messages from the feed get posted. Server logs show that Stack Exchange servers do make a request every ~30 minutes to the feed, but I'm still not seeing anything in chat.

For reference, this is a minimal version of my custom feed:

<feed xmlns="http://www.w3.org/2005/Atom">
  <title type="text">MS posts | Charcoal</title>
  <link rel="self" href="https://metasmoke.erwaysoftware.com/api/v2.0/posts/search.atom" />
  <link rel="self" href="https://metasmoke.erwaysoftware.com/search" />
  <subtitle>Posts matching search criteria from metasmoke.</subtitle>
  <updated>2017-12-29 18:11:45 UTC</updated>
  <id>https://metasmoke.erwaysoftware.com/api/v2.0/posts/search.atom</id>

  <entry>
    <id>https://metasmoke.erwaysoftware.com/post/78101</id>
    <title type="text">test</title>
    <author>
      <name>username</name>
      <uri>https://stackoverflow.com/users/12345678</uri>
    </author>
    <link rel="alternate" href="//stackoverflow.com/a/446231" />
    <published>2017-12-29 18:11:45 UTC</published>
    <updated>2017-12-29 18:11:45 UTC</updated>
    <summary type="html">&lt;p&gt;test with html&lt;/p&gt;</summary>
  </entry>
</feed>

What do I need to include/exclude for chat to accept and post the feed?

You must log in to answer this question.

Browse other questions tagged .