2

The Users page seems to display all the users on a single line, as shown in the picture below:

Users page borked

For the record, I am using a Macbook (early 2015), running macOS 10.12.2 running Safari 10.0.2. The bug appears to occur on all SE sites. Other users there weren't able to reproduce this, so I think it might be some of the new CSS changes which is incompatible with Safari 10.

Edit

This one seems to have been fixed... But everything is heavily misaligned now:

Users page borked II

  • @ShadowWizard I emptied all the caches and disabled all the userscripts I had enabled. Anyway, I am pretty sure that the userscripts I was using have nothing to do with the users page. – Mr. Xcoder Mar 13 '18 at 14:29
  • Never mind, you're correct. Posting an answer. – Shadow The Princess Wizard Mar 13 '18 at 14:33
4

SE switched recently to use CSS Grid Layout in the Users page, which is indeed not supported in Safari 10. (and IE 10 too)

Since SE should support last two versions, I think they should revert that change and use whatever they used before to support older versions for now.

Until then, you can upgrade to Safari 11 and it will work.

  • Thanks for the info! Until then, you can upgrade to Safari 11 and it will work. – I wish I could (having limited disk space prevents me from updating macOS and consequently Safari :|, etc.)... – Mr. Xcoder Mar 13 '18 at 14:36
  • @balpha need to add a fallback rule. He has done that for other browsers, like FF 52. – rene Mar 13 '18 at 14:37
  • @rene you mean balpha. (let's not make him angry! ;)) – Shadow The Princess Wizard Mar 13 '18 at 14:38
  • 1
    Phheeewwww, edited just in time ... thanks! – rene Mar 13 '18 at 14:39
  • There is a fallback for browsers that don't support grid. @Mr.Xcoder It looks fine to me in Safari 10.1, can you at least update to that? – balpha Mar 13 '18 at 16:01
4

Thanks for reporting. Fix for that older version of Safari is coming. Although I wasn't able to test exactly that version but I checked on previous one and it looked fine.

  • What went wrong then, if we can ask? – Shadow The Princess Wizard Mar 13 '18 at 16:38
  • Ugh, that seems to be fixed but now I encounter this... – Mr. Xcoder Mar 13 '18 at 20:16
  • @ShadowWizard nothing went wrong actually – older version of Safari required some additional CSS to make it wrap correctly. – Paweł Mar 14 '18 at 9:49
  • @Mr.Xcoder whoops, missed that one. I will take a look but can't promise anything. If it requires lots of work then I'm sorry – it's usable/readable enough even if it's misaligned. Is there any way you could update your Safari to 10.1 at least? Don't get me wrong - I really wanna help but also don't want to end up having lots of CSS hacks only to support outdated browser with marginal traffic. And since we're trying to introduce responsiveness, some changes are required. – Paweł Mar 14 '18 at 10:01
  • It all seems to be fixed now. I really wish I could update at least to Safari 10.1... I'll see what I can do. Anyway, thank you very much for your time! – Mr. Xcoder Mar 15 '18 at 14:36
  • Cool, I'm glad it works(-ish)! – Paweł Mar 15 '18 at 14:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .