3

Currently, on any chat message, there is the "reply" button that automatically inserts the required markup to reply to a certain message. This includes messages from deleted users.

However, if you use the button to insert the reply code on a message that was posted by a user with a deleted chat profile, and then post your message, the message isn't actually a reply: it just shows the code number at the beginning. It also doesn't highlight the message it was trying to reply to on mouseover, as most normal uses of the reply button would.

Since you can't reply to messages from deleted users, one way to fix this bug is to stop showing the reply button on messages from deleted users. Another way is to allow replying, showing the message as a reply, but not actually attempt to ping the deleted user.

Update: I ran into another instance of the same thing just today. I attempted to reply to a message from a user who had just deleted their account, but my chat page hadn't refreshed to show their account deleted. I attempted to reply to it, and it showed the old username in the message initially but with no reply markup. I refreshed the page, and it showed the code number instead of the old username.

4
  • IMO it should be available, the problem is what name to show since the user is deleted. One way is showing Community, as the case of post activity from deleted users in some cases. – Shadow Wizard is Vaccinating Apr 16 '18 at 18:06
  • @ShadowWizard You could show the displayed name, "user123456". – Sonic the Curiouser Hedgehog Apr 16 '18 at 18:07
  • Yeah that's also valid option. – Shadow Wizard is Vaccinating Apr 16 '18 at 18:08
  • 1
    Given that there is currently no development time being allocated to chat I don't think this will get fixed in the normal 6-8 weeks. Maybe 6-8 millennia? – DavidPostill Apr 18 '18 at 10:51

You must log in to answer this question.

Browse other questions tagged .