22

Earlier today I asked my first question on this site. So Meta SE was added to my accounts. But this account is shown three times:

MSE account showing three times

One of them also has a badge while the other two don't.

The network profile doesn't show MSE at all:

Also I have got this long wierd user name and I am not able to change it. In the edit- display name this long name is not there.My user name on other sites is shown there.

After all this happened Meta SE questions are not getting loaded in my SE app.

Edit: the issue of name is solved now. I changed the profile picture and saved changes and it worked.

  • 2
    They are separate accounts with separate (consecutive) user IDs, but all seem to be connected to your other accounts... very strange – Cai Apr 21 '18 at 16:00
  • What to do about this weird thing? – dssknj Apr 21 '18 at 16:10
  • 1
    You wait until a SE employee finds this question. It’s the weekend in New York, it might be a few days, before it can be fixed. – Ramhound Apr 21 '18 at 16:17
  • 3
    Funny enough this happens more often – rene Apr 21 '18 at 16:48
  • i.stack.imgur.com/Eb5h5.jpg – Sathiya Kumar Apr 22 '18 at 5:03
  • Short version: we had an issue over the weekend where a prod build was missed on a project or two, so database migrations didn't run. That has been fixed, so new profiles should be created fine. We're working on fixing up the affected accounts. I'm gonna leave it to the dev doing that to post the final resolution/answer, though. – Adam Lear Apr 23 '18 at 20:28
  • @Adam thanks, I hope to remember reminding you in 6-8 weeks. :-) – Shadow Wizard is Vaccinating Apr 23 '18 at 22:09
4

This was my fault. I had removed some code in a shared library, and built the changes out everywhere... except for the web app that services the Mobile app, where you were getting the errors :(

Everything should be good now and the bad data has been fixed.

My apologies!

  • Did it also cause new profiles to get weird GUID-like display names? (there were few such bug reports in the last few days.) – Shadow Wizard is Vaccinating Apr 24 '18 at 15:18
  • Yes, a new user is initially created with a GUID for its display name and will have it changed in a later step. Due to the bug, this rename never occurred :( Although it's unsightly, it makes it easy to find invalid users. – Jarrod Dixon Apr 24 '18 at 15:22
  • Thanks. So this bug report is actually duplicate of the one here, no? Not sure if worth to close it though, or post new answer there explaining the root cause. Leaving this up to you. – Shadow Wizard is Vaccinating Apr 24 '18 at 15:34
  • Yup! Good catch! – Jarrod Dixon Apr 24 '18 at 16:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .