I just posted a question on Stack Overflow dealing with a specific AWS Data Pipeline configuration question. I have a second unrelated AWS Data Pipeline question I also need help with, but when I click the Ask Question button it keeps opening the edit screen for my previous question I posted.

I've tried clicking on the Ask Question button from the home page, but the same thing happens. Can I not ask two questions simultaneously within a certain time period or is this a bug? If needed, here is the first question I was able to post.

  • 2
    Probably the draft didn't get discarded for some reason. Just remove the text.
    – rene
    Commented May 15, 2018 at 15:05
  • @rene ah that was it I must have had a draft that wasn't saved. That was a little bit confusing. Commented May 15, 2018 at 15:06
  • 1
    @Servy are you sure it is rate-limiting?
    – rene
    Commented May 15, 2018 at 15:07
  • 1
    On another note: are you sure those questions are on-topic on SO? They seem more dev-ops / server related then programming but I'm not much into AWS so I can't judge.
    – rene
    Commented May 15, 2018 at 15:08
  • @rene Possibly I didn't think about that. I'm technically a developer and not devops so I've never used the DevOps or Server pages. Maybe I'll check those pages now for some solutions thanks. Just found this thread detailing your point meta.stackexchange.com/q/141942/263294 Commented May 15, 2018 at 15:10
  • 1
    @Mr.Tea yeah, it is a bit of a grey area. If you script those configurations against an API it could be on-topic. If you're just configuring stuff it becomes murky.
    – rene
    Commented May 15, 2018 at 15:12
  • 1
    Drafts are tied to posts, so .. I'm going to leave the bug tag here because the behavior sounds a tiny bit off from how I thought it worked (that could have changed, but I'd like a dev to at least see this prior to calling it a support request). What's supposed to happen falls in line with what you explained in your answer, but I think you should have seen two different drafts, which is what caught my eye here.
    – user50049
    Commented May 15, 2018 at 15:45
  • @Servy It's not rate limiting because if it were, the OP would receive an error message, which isn't what's described here. Commented May 15, 2018 at 15:48

1 Answer 1


As @rene pointed out in the comment it was an unsaved draft. That was sort of confusing though because I clicked on Ask Question and wouldn't have thought that an edit draft from another question would show up. I'd expect that draft to show up only if I clicked on the edit button of the question.

Not the answer you're looking for? Browse other questions tagged .