1

I ran into a strange issue; there's a question (How do I get from an instance of a class to a Class object in ActionScript 3?) that is fairly old (October 15th, 2008) that I found useful. I've never voted on it before, but when I tried to vote it and its answer up, I got "Vote too old to be changed, unless this question is edited". That seems to be wrong; I haven't ever seen this question before (and notably the vote arrows don't indicate that I've ever voted on it).

This is occurring with svn revision: 5620.

2

I am able to reproduce this.

In Firefox if you upvote the question and then click the question title (refresh) your vote will disappear - the vote is counted by SO and can be viewed by clearing the cache or loading the page in another browser.

My guess is that you upvoted the question but your cache doesn't have the most up to date version of the page. When you click the upvote button you then get the message.

Is there a different cache expiry placed on older questions? Something like that may cause this issue...

  • I don't think it has anything to do with the age of the question, I just had a similar problem in a meta question a few minutes ago. – Brandon Nov 26 '09 at 18:46
3

You did vote on it before, but the net result was +0. In other words, you voted and undid your vote.

  • Thanks for the explanation... but it seems kind of silly to have it set up that way. Sometimes I reverse my vote when I read the first half of the answer, realize it'll be complex to implement, and want to hold off my vote until I test it tomorrow to make sure it works first. Has there been discussion around this topic? IMO, it'd be better if this didn't engage the "Vote too old" logic. – Dan Mar 16 '10 at 5:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .