I fail to understand how to get emails when questions I have asked get answered, or when questions I have responded to get more comments or answers. Many of the questions I found seem to apply to older versions of Stack Exchange.

I tried adding a filter on 'favorite' tags, but that seems to include every single Q&A that someone has added an explicit 'favorite' tag to, which is not (I think) what I need.

I am aware that there is a 'favorite' button alongside questions, but I cannot for the life of me figure out how to filter on that for those I have marked.

I have to say the user interface for Stack Exchange is the one of the most confusing, to me, of any forum I use. Every time I come back I seem to have to dig around to find out where my profile is, and so on. I'm not even sure what the overall setup is, with 'Meta' and so on. It's all something of a puzzle.


2 Answers 2


When you ask a question or write an answer, there appears an option below selecting tags and above "Post your question" called " Email me new responses to my posts". Select that option.

Gif showing selecting email response

This only appears when you are writing a question or answer. This feature is helpful when you only want Email notifications from specific posts from a site and not all. Changing Email settings affect all the sites you are a member of. If you have missed some responses, you can always go to your profile page and select "responses" tab. All the responses from community to your posts are present there.

  • 1
    I have never seen that, and as I write this comment I still don't see it. I must be missing something about how this site works. Jun 3, 2018 at 14:27
  • 1
    @TimPassingham It appears only when you post a question or answer.
    – Nog Shine
    Jun 3, 2018 at 15:31
  • @NogShine I started to compose an answer to this question (as a test) and that did not appear. I then started to compose a question (as another test) and it was still missing. At least for me, on this site, that is not an available option. Jun 3, 2018 at 18:15
  • @JasonBassford I checked it again. It appears to me on all the sites. Please check once again.
    – Nog Shine
    Jun 4, 2018 at 1:50
  • @NogShine It definitely doesn't appear for me. (Not that it actually matters in my case, because I don't want to get email . . .) Jun 4, 2018 at 1:53
  • @JasonBassford Here's the image. i.stack.imgur.com/5tLN3.png I found that it doesn't appear only when you are answering your question. Otherwise, it appears.
    – Nog Shine
    Jun 4, 2018 at 2:01
  • I'd never seen this either... Just did some testing and seems it's only visible if you have inbox emails "off" (here). (I'd actually never turned inbox emails on and have never received any, but it was turned on in the settings; turning if off made this checkbox appear)
    – Cai
    Jun 4, 2018 at 8:46
  • @Cai I have never changed my e-mail settings anytime. My settings are default settings. This check box was visible to me all the time.
    – Nog Shine
    Jun 4, 2018 at 9:05
  • 1
    @NogShine Sure, I'm not saying otherwise, but the checkbox doesn't appear unless you have those emails turned off and I (and OP it seems) had them on (despite never turning them on or ever receiving an email; which I guess was messed up at some point when they recently made changes to email notifications)
    – Cai
    Jun 4, 2018 at 9:09
  1. Go to your profile page on one of the sites you're a member of.

  2. Click on "Settings":


  3. Go to "Edit email settings":

    edit email settings

  4. Under "Inbox" choose the frequency in which you want to get emails:

    email frequency

That is it. After choosing the frequency, you'll start getting emails for your unread inbox items, in all sites you're a member of. Note that reading the items will prevent emails.

Note that three hours is the minimum frequency; a request for instant email notification has been declined in the past.

  • Thanks. However, that is set to Daily (I have never changed it), but I've never had an email. I'll reset it and try again, without coming back to see if there are any comments or answers. Jun 3, 2018 at 9:26
  • @Tim make sure the email in the "edit email settings", in the first textbox, is correct. You might have changed it in the past and forgot about it. Also, by clicking the inbox notifications on the site you "clear" them aka mark them as read, and they won't be sent via email. Jun 3, 2018 at 9:30
  • 1
    I had checked, and my email address was correct, but having changed the setting to 3 hours it worked. Thanks. Jun 3, 2018 at 14:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .