2

I see some SE sites moving to the new format, such as MSE, and this appears to work on my desktop and mobile. Most of the others are on the old format, which again works well on desktop, and is passable on mobile.

However, a couple of sites do weird things. Outdoors is especially strange - I assume it has some messed up formatting. See here - there is no nav bar, right hand column, no review link, etc:

Enter image description here

I have turned off Ghostery and Scriptsafe blocking temporarily, the SE chat extension makes no difference, and I am running no scripts under TamperMonkey. It's an up-to-date Windows 10 install.

By comparison, here is how my machine renders MSE.

New layout, but all working (even if I don't quite like it as much as the earlier version...):

Enter image description here

marked as duplicate by Glorfindel, Nathan Tuggy, Robert Longson, rene, Sonic the Inclusive Hedgehog Jul 4 '18 at 19:03

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Isn't the top screenshot the old (current) mobile layout? In the second screenshot just FYI, the left navbar can be collapsed into a menu button on the site preferences page with the "Hide left navigation" tickbox. – MoonRunestar Jul 4 '18 at 16:07
  • There is no way to get to a site preferences page from the top screen. I don't know how I would be served the mobile layout for Outdoors and a couple of others... – Rory Alsop Jul 4 '18 at 16:12
  • Usually to get to the mobile version of the site you click on the "Mobile" link in the page footer. To get back to the full site, you can click the "Full Site" link in the footer. From the limited testing I've done, the mobile site preference appears to be on a per-site basis, which is most likely why you're seeing this on specific sites. – MoonRunestar Jul 4 '18 at 16:21
  • 1
    Ahhhhhhh - erm. I feel a bit daft, but if you want to post that as an answer, it worked ;-) – Rory Alsop Jul 4 '18 at 16:23
2

Stack Exchange sites are displayed in their mobile layouts if you:

  1. Use a mobile device to visit the site
  2. Click on the "Mobile" link in the footer on the full site

Somehow you must have clicked on the mobile link or triggered whatever detects if you're on a mobile device.

To override this, you can click the "Full Site" link at the bottom of the mobile page, located in the footer. You'll have to click the Full Site link on every site that is affected as this preference isn't network-wide unfortunately :^(

Not the answer you're looking for? Browse other questions tagged .