13

I was auto-logged out from the chat.stackexchange.com server. And I couldn't log back in! I reproduced this issue both on Chrome 67 and on Firefox 61, both with regular tabs and Private / Incognito tabs. My OS is macOS 10.13.5.

What I tried:

  1. on chat.stackexchange.com, click the 'login' button (top right, next to the search box).
  2. click the log in with Stack Exchange button.
  3. fill in my Stack Exchange login credentials.
  4. I'm redirected to https://stackoverflow.com/users/login?teamsMember=1, a page that tells me with a red box that I need to log in directly, since I'm a team member:

    login page with red admonition for team members to log in directly

  5. Fill in my credentials again. Now I'm logged in to Stack Overflow.
  6. Return to chat.stackexchange.com, confirm I am not logged in there.
  7. Try the same flow again. Log in link, use log in with Stack Exchange, fill in credentials. Now I am taken to a page on Stack Overflow that states I am logged in, and asks me to add another way to log in?

    Page telling me I am logged in and stating I can add another log in

So the log in flow wants me to log in on Stack Overflow, and that log in is never reflected back to Stack Exchange. I can't log in on https://stackexchange.com either. On step 3 I can also use my OpenID URL (which is backed by the Stack Exchange OpenID service for now until I can figure out how to rescue my SEDE account queries) but this has the exact same result.

The work-around is to log into https://meta.stackexchange.com (or any one of the other *.stackexchange.com sites, such as https://codereview.stackexchang.com), then suddenly chat has me logged in as well, and https://stackexchange.com acknowledges my account exists too.

  • That a login into meta.stackexchange.com works is probably caused by the fact that they share the same top level domain name and with that the cookies. Probably any site you have an account on that is hosted under stackexchange.com should work, for example login in to codereview.se should work for you as well. (not saying this solves it, just testing / verifying the hypothesis). – rene Jul 18 '18 at 9:52
  • @rene: yes, that's pretty much my hypothesis as well. And indeed, logging in to Code Review also works. I've added that to the post, thanks for helping improve the diagnosis here! – Martijn Pieters Jul 18 '18 at 10:06
  • Reproduced too on Chromium 67.0.3396.99 and Ubuntu 16.04 – ɥʇǝS Aug 6 '18 at 1:34

You must log in to answer this question.

Browse other questions tagged .