2

Somehow I got logged out of Chat and SE in general recently. I logged back into Super User successfully using Chrome, but when I went to Root Access I was told that I need to log in to chat:

ra nochat

So I hit login, used my StackExchange ID, and got punted to... StackOverflow to 'add a login'?

SO

Well, that was weird but at least I'm logged in to chat now, right? Or not:

chat nologin

I tried again but the process repeated itself. I also tried logging in via https://stackexchange.com but that also punted me back to SO without logging me in. Same effect after deleting all related cookies and incognito mode*.

A bit of searching dug up Unable to log in to chat.stackoverflow.com, which seemed promising. So I went to post a query on Meta about this - I had to log in to Meta as well - and started writing.

Loading up chat now shows me as logged in! I tried this again and was able to replicate.

What gives? I recently joined an SO Team, perhaps this has something to do with it?

tl;dr sequence

  1. logged out
  2. log in to chat using StackExchange ID
  3. redirected to SO 'add a login'
  4. still not logged in to chat
  5. log in to Meta
  6. chat now logged in

Why does logging in to Chat (or StackExchange) redirect me to StackOverflow 'add a login'? And why can I log in to chat via Meta?


*: I wanted to test via Firefox but ran into a different issue there ("3rd party cookies seem to be disabled" → log in manually → StackExchange OpenID "Not found") which I can create another question for.

marked as duplicate by DavidPostill, Nathan Tuggy, curiousdannii, Ward, rene support Jul 18 '18 at 18:56

This question was marked as an exact duplicate of an existing question.

  • 1
    This seems related: meta.stackexchange.com/questions/312664/… – rene Jul 18 '18 at 9:44
  • as for the 3rd party cookies: That is by design. Your browser needs to accept 3rd party cookies as Universal Login relies on it. – rene Jul 18 '18 at 9:45
  • @rene agreed; that looks like it's a very similar, quite possibly the same issue; missed that in initial search! – bertieb Jul 18 '18 at 9:50
  • I don't ever remember disallowing 3rd party cookies and I agree they are needed; but the issue I was getting at there is SE's own OpenID dealie is giving a 'not found' page on login – bertieb Jul 18 '18 at 9:51
  • Yeah, there is something broken in the login flow, probably after SO for Teams got added. This needs Adam Lear to look at but they are on leave now for another 3 weeks I believe. – rene Jul 18 '18 at 9:55
  • In this new era of everything getting more secure and browsers trying to protect their users privacy it might as well be a silent switch to disallow 3rd party cookies. – rene Jul 18 '18 at 9:58
  • I'm 99% sure I allow 3rd party cookies (or at least never disallowed them) and I have this same issue – mag Jul 18 '18 at 10:52

Browse other questions tagged .