4

It has happened several times now that I have tried to answer a question on a site, and I keep getting a CAPTCHA that just will not show up!

Is there a browser setting I need to change? I'm currently using Firefox.

  • Do you have Google domains blocked? – animuson Jul 21 '18 at 2:53
  • @animuson I'm not sure. It appears to happen when I try to post an answer on a stack exchange site that I'm not part of the community for and thus not recognized as logged in. – prayreadgame Jul 21 '18 at 3:18
  • Well we use Google's reCaptcha service, so if something on your computer or network is blocking the domain, then it won't load into the page. It's almost always the problem with it not appearing. – animuson Jul 21 '18 at 3:19
  • @animuson how would I go about fixing that? Use Chrome instead (works slow on my computer)? - Using Chrome instead seems to work, but what might I have wrong on Firefox that it won't work there? I'm not a fan of Chrome. – prayreadgame Jul 21 '18 at 3:21
  • I've had websites misbehave if the "tracking protection" option is set to "always". Changing to "Only in private windows" gets them working better. I don't know if that's the issue here. – 1201ProgramAlarm Jul 21 '18 at 4:15
  • @1201ProgramAlarm I think that probably is the issue as I like to keep tracking turned off. Thanks! I'll accept your answer if you want to post it! – prayreadgame Jul 21 '18 at 4:18
3

Change the "tracking protection" option from "always" to "Only in private windows" or "Never". You can change it back when you're done.

Tracking protection is a feature in in Firefox that "blocks online trackers that collect your browsing data across multiple websites." With it always on, some web site functionality that relies on cross site stuff doesn't work. While this is frequently useful, sometimes it breaks functionality you're looking for.

Below are some pictures to make the process more clear for people who have this issue in the future:

  1. Go to the Firefox menu by clicking this icon in the upper right hand of the window:

    Firefox Menu

  2. Navigate to the Options portion of the Firefox menu

    Firefox Options

  3. Select the 'Privacy and Security' tab

    Privacy and Security Tab

  4. Finally, navigate down to tracking protection and make the change.

  • 2
    What is "tracking protection"? The answer is unclear and useless for people other than OP, or those familiar with this term. – Shadow The Princess Wizard Jul 21 '18 at 8:36
  • 1
    @ShadowWizard, the answer is clear for this type of question because asker does not want to know that term, he just wants solution. For specific task of tracking protection, people need to ask new question if not exists. However, additional info about terms in answers are still preferred. – WailenB Jul 21 '18 at 10:15
  • @ShadowWizard "Tracking protection" is one labeled section of options in Firefox specific to that browser. It is not necessary to know exactly what it does to be able to change the option. The browser itself says "Tracking Protection blocks online trackers that collect your browsing data across multiple websites" with a link for additional information. I've edited my answer to add an explanation. – 1201ProgramAlarm Jul 21 '18 at 20:15
  • Well, it's not trivial how to reach it. One who isn't familiar with Firefox settings will have to look and search how to reach it. Good answer, in my opinion, should save that extra step, e.g. "Go to Firefox setting, from there go to "tracking protection" option etc etc" – Shadow The Princess Wizard Jul 21 '18 at 21:07
  • 1
    @ShadowWizard I added some screenshots. Hopefully that's sufficient for people in the future. – prayreadgame Jul 21 '18 at 21:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .