10

To reproduce:

  1. Go to Travel.SE (not sure if other sites are affected)
  2. Pick any post
  3. Lock it for 1 day or longer
  4. Bug: after 1 hour Community will unlock the post regardless of the setting above

Here's a timeline of one our posts where this happened twice.

  • Umm … It’s unrelated to this bug, obviously, but I don’t see the “content dispute” there. The edit does fix spelling and grammar mistakes and should be uncontroversial. Why the rollbacks? – chirlu Jul 22 '18 at 18:13
  • 1
    @chirlu changed the link to a different locked question where the reason is more clear :) – JonathanReez Jul 22 '18 at 18:15
  • Am I missing something? Looks like your example is locked for (what remains of) 24 hours right now. The default for "content dispute" is 1 hour - perhaps you forgot to change it? – Shog9 Jul 23 '18 at 1:16
  • @Shog9 I've tried to lock it again after I posted this bug report and the lock seemed to have taken hold now. However previously it didn't work and the lock was taken off after 1 hour. – JonathanReez Jul 23 '18 at 1:40
  • Ok; I'm testing a theory here via a "permanent" lock. If this gets unlocked after an hour, that's the bug; if it doesn't, it's status-norepro. – Shog9 Jul 23 '18 at 1:51
  • 1
    Can't reproduce; tried here on meta and on Travel. Lemme know if you encounter this again please! – Shog9 Jul 23 '18 at 3:40
  • @JonathanReez any chance for userscripts on your side that might have somehow messed with the JS/HTML involved? (i.e. did you install any userscript related to SE?) – Shadow Wizard is Ear For You Jul 23 '18 at 11:21
  • @ShadowWizard I think it was some sort of a temporary glitch. It affected both me and another mod yesterday (as seen in the timeline) but then today all is well again. – JonathanReez Jul 23 '18 at 14:17