Update: Custom question lists October status update

We are excited to release the first phase of custom question lists for alpha testing. Check out Custom question lists: finding questions you can answer for a refresher on the feature. A reminder that the functionality being released is a new experience for selecting the question lists and new filter/sort controls. The ability to save and reuse "custom lists" comes in phase II.

Note: This functionality is being released on Stack Overflow, Meta Stack Overflow and Meta Stack Exchange. Once it is out of alpha, it will be available on all network sites.

How to opt into the alpha

1. Go to your user preference

2. Check "Opt me in" for the "Custom Question List" feature

Custom Question List alpha preference note: set it once and the feature (when active) will be available on SO, MSO, MSE.

3. Wait.

You won't be immediately opted in. At first your status will be "Pending". We are limiting the number of people who have access. This will let us find/fix issues with less disruption. And, it will let us manage the load that this new feature puts on the servers (this could be more of an issue in phase II).

4. Test away.

When you do get access to the feature, please try it out. Log bugs as answers on this post.

Schedule for future improvements

This feature will roll out in four phases:

  • Phase I: Filter and sort controls to let you modify a question list view (Julyish)
  • Phase II: Saved custom lists (In progress, ETA November)
  • Phase III: Notifications on custom lists (December)
  • Phase IV: Final fixes and official release (January)
  • 6
    Just a question, how can we know we have been "given access" – DarkCygnus Aug 9 at 21:08
  • 2
    @DarkCygnus #1 You'll see the changes on the /question page. and #2 you'll see "Active" on the preference (as shown above). We will enroll anyone who chooses it in the next 90 minutes or so. Then we will add more tomorrow. – Joe Friend Aug 9 at 21:10
  • 5
    I'd be happier if you just provided a way for us to search through our previously answered questions to help with duplicate locating :) Paging through thousands of previous answers 25 at a time is no fun. – David C. Rankin Aug 12 at 9:50
  • 1
    @DavidC.Rankin I'm not sure what you're asking for. The SE search interface already has the ability to search only posts which you created. When viewing your profile, the default search from the topbar already filters for just your own posts. For instance, searching all of your answers on SO in the 'c' tag which contain printf in code this search. – Makyen Aug 20 at 0:20
  • @Makyen I always knew the SE folks were ahead of the game, but I must admit, I looked for that feature, and I'm glad to know it is there, but I couldn't find any search whatsoever that looked like it was limited to my answer (granted, I'm no html, js, search programmer, but the user:xxxx in the search box, now that I know what I'm looking at, is a big hint). So it is the user:xxxx prefix that limits the search to your account, that is great! Consider the request filled before it was made :) – David C. Rankin Aug 20 at 1:46
  • 5
    @DavidC.Rankin You can even do user:me, instead of filling in the number. – Nisarg Shah Aug 20 at 8:21
  • Any chance we can get an update on this? Even if it's only telling we will have to wait a week or so for an update :P – André Kool Aug 30 at 17:06
  • 1
    @AndréKool Progress on this slowed for August. We are still actively working on it and want to release an update for continued testing. However, the next phase is where the biggest chunk of complexity is so you'll need to be a bit patient. The dev working on this will provide an update later in September. – Joe Friend Aug 30 at 18:18
  • 2
    Thank you for the update. I understand it's busy but it can get a bit frustrating to hear nothing. And seeing it pop up on Meta stackoverflow nudged me to check up on it :) – André Kool Aug 30 at 18:21
  • @JoeFriend It's been "pending" for weeks for me. Have you stopped accepting opt-in requests? – Ahmed Abdelhameed Sep 9 at 20:16
  • Is there any update regarding this? Phase II seems to been due for one month already... – MEE Oct 4 at 14:55
  • I'll update the schedule soon. Sometimes things take longer or get disrupted. This is one of those cases. – Joe Friend Oct 10 at 16:27
  • 1
    @JoeFriend, how about that schedule update? Or did I just miss it reading this page? – Luuklag Oct 21 at 15:38
  • 1
    @Luuklag updated above. We are actively working on this but our schedule was decimated by summer vacations and a variety of other disruptions. Sorry for the delay. – Joe Friend Oct 23 at 16:56
  • Thanks for the update @Joefriend – Luuklag Oct 23 at 18:54

22 Answers 22

Please add a results count at the top of the screen, like we have when doing normal searches. Note the difference between search:

Results count on question search

And question list:

Missing results count on question lists

  • 3
    Yeah, this gets frustrating fast when trying to manage tags. – Shog9 Aug 15 at 22:04

Using the browser's back button doesn't play nice with the new filter. Example:

  • Navigate to the 'active' tab: https://meta.stackexchange.com/questions?tab=Active
  • Click the 'bounties' tab
  • Click the browser's back button, you're now back on the 'active' tab
  • Scroll to the bottom and click the button for another page 2. You'll either get a 404 page or the message that there are no questions found, while the 'bounties' tab is again selected.

(This problem doesn't happen on other sites, that's why I'm blaming the custom question filter.)

  • 12
    This is definitely a bug - I'll get this fixed. – Jon Chan Aug 13 at 16:16
  • This has been fixed as mentioned in the October update. Paging was using the non-CQL URLs and because of the way the tag preferences are saved, when it when it couldn't recognize the sort it used the last sort that was used on the server, "Bounties". – Brian Nickel Nov 1 at 22:15

/

Once the menu is opened, if I click elsewhere (without changing anything), the page refreshes. This is a bit irritating. I might just want to see what options I have set, but as soon as I open the menu it is bound to refresh the page as it closes.

Please consider giving an "Ok" button to confirm changes (and refresh the page), or a "Cancel" button to discard changes (without refreshing pages) or both.

  • 6
    I also noticed this. Every time you close the filter dropdown it refreshes the page, even though you didn't change settings – DarkCygnus Aug 10 at 18:03
  • 1
    I can't reproduce. I'm on Chrome 68.0.3440.42 if it helps. – Rakete1111 Aug 11 at 22:36
  • 1
    @Rakete1111 Yeah, I can't reproduce either. They might have fixed it. – Nisarg Shah Aug 12 at 6:38
  • 3
    @Rakete1111 Looks like you need to have at least two tags specified in the filter to repro this. – Nisarg Shah Aug 12 at 15:17
  • 10
    @NisargShah I've been able to reproduce this with two or more tags. I'll get this fixed. – Jon Chan Aug 13 at 16:18
  • 1
    It also refreshes the page when I click “reset”. I want to reset filters, then apply new ones, then refresh the page. I mostly use this to update “My watched tags”. Maybe, if the filter is selected, the view should update automatically, or at least with an “update watched tags” button? – Xufox Aug 16 at 23:06

The old UI allows opening the various filters in new tabs:

old ui - open link in new tab

This is no longer possible. It appears that what used to be <a> links are now <button>s:

new ui - no open in new tab

May be related to https://meta.stackexchange.com/a/313986/281829

  • This has been fixed as mentioned in the October update. The tabs are now links with their proper URLs attached. Previously we were using JavaScript for navigation which broke this functionality. – Brian Nickel Nov 1 at 22:19

What is the point of the "no answers" and "no accepted answers" filter options? I think it is so that we can find questions that we'd like to answer. But if that's the case, why are closed questions not filtered out?

If there's some other purpose to those options, I'd be happy to hear it. But otherwise, it seems to me that we need to (1) automatically filter out closed questions when choosing the "no answers" or "no accepted answers" options, and/or (2) add a "closed" checkbox to the filter dropdown.

I realize that we'll be able to do fancy custom search strings in Phase II, but it seems like a tool meant to help people find questions to answer should have the built-in ability to easily hide closed questions.

  • Pretty sure this is just a bug per Nisarg's answer here. If they included the filter options, they surely were meant to work, and they aren't working right now. – TylerH Aug 10 at 21:19
  • 1
    "No accepted answers" should be working correctly with regards to filtering out closed and locked questions. It maps to the same sorting used by the Unanswered tab today. "No answers" is probably showing them though. I'm planning to implicitly filter out closed questions in the Phase 2 update. – Brian Nickel Nov 15 at 21:38

/

I successfully tried using some filters and got the posts displayed (for example: my tags, no answers, no accepted, today).

I see that "today" there were (as of this moment) 28 pages of results, with 50 results per page, that matched my tags and the parameters chosen:

enter image description here

I then proceed to press next, to see the rest of the target questions, but when I do the filters are reset.

I can see this because my filters disappear (only the "All time" remains) and there are now a whole lot more pages (52,218 as of this moment):

enter image description here

How can I see the next page of questions that meet my filters?


Edit: Looking closer, I see that although the filters are gone and now there are many more questions, they are still ordered according to the filters I gave it.

It's like we appended the rest of the questions at the end of those original 28 pages returned. Still, the filters on the interface are "reset", although the tag(s) description on top of the filters remains displayed.

  • This has been fixed as mentioned in the October update. Paging was using the non-CQL URLs and because of the way the tag preferences are saved, when we couldn't parse that URL correctly changing pages was taking you to a different tag list. – Brian Nickel Nov 1 at 22:37

Indicate whether filter option "today" means "created today" or "last active today" – perhaps in a tooltip.

In search, according to help, there are two available time parameters: created and lastactive.

It's not immediately clear which of these two parameters is used in the question lists feature. If it's not convenient to display this all the time, at least stick it in a tooltip that appears when hovering over "today," "last week," and "last month."

Time filter but no indication as to what is meant

  • 1
    As mentioned in the October update, I'm going to just remove these options. Like your post says, their definition is unclear, and I don't think they really add value beyond the "Most Popular" sort they were designed for. If you disagree with that assessment, please let me know. – Brian Nickel Nov 1 at 22:39
  • @BrianNickel I think this makes sense. But in your update, I didn't notice any indication that in phase 2 or 3 we'd be able to enter (and save) manual search strings (which could include things like created and closed:no). Is that still part of the plan? – Nathaniel Nov 2 at 19:39
  • There's no plan to incorporate rich search strings into CQL. It will support the complex tag expressions available on tag pages today (like javascript -jquery or python -numpy) but not things like lastactive. – Brian Nickel Nov 15 at 21:42
  • @BrianNickel Oh... That's too bad. I suppose I'll have to hang onto my browser bookmarks for some things then. Thanks for the clarification. – Nathaniel Nov 16 at 1:08

I can already see the changes took effect. Not precisely a bug (or perhaps is bydesign), but I noticed that the new interface only appears when going to the /questions link:

enter image description here

However, this is not visible from Home (that is without the /questions):

enter image description here

I see this is the case for all 3 test sites. Is this behavior intended?

At first I was confused as I was "Active" but didn't see the changes, until I pressed Questions is that I saw the layout change.

  • 5
    Correct. The ux changes are only available on /questions for now. – Joe Friend Aug 10 at 0:58
  • 2
    @JoeFriend I take that, after that phrase, we will see it on home after phase 1, correct? – DarkCygnus Aug 10 at 7:43
  • 2
    I'd rather that the home page present a consistent view to everybody. Home is where I can get the unfiltered view that everybody sees; /questions is where I can get my custom view. Both are valuable, especially for site custodians. – Monica Cellio Aug 13 at 18:24
  • @DarkCygnus Home is TBD. – Joe Friend Aug 14 at 17:31

I can't find the Custom Question Lists option, neither here nor on Meta Stack Overflow (but on Stack Overflow, it works now).

enter image description here

  • 10
    Should be fixed now – Joe Friend Aug 9 at 21:06

Entering along with other tags in the Filter box replaces the with

enter image description here

After clicking out of the filter box:

enter image description here

  • 2
    It's not just c++. At first look its every tag that includes a + – André Kool Aug 14 at 18:43
  • 1
    It looks like the c%2b%2b gets replaced with c%2B%2B, which is apparently interpreted as c – Justin Aug 17 at 18:05
  • 1
    As a workaround while we're waiting for it to be fixed, click in the search bar and add the ++ manually: [cmake] or [c] -> [cmake] or [c++] – Justin Aug 21 at 21:17
  • Looks like it doesn't happen when you only enter a tag with a +. Weird – André Kool Aug 30 at 17:05
  • 1
    This has been fixed as mentioned in the October update. We were properly encoding c++ to c%2b%2b, but then were were still separating tags with +, so by the time we were parsing it we only say + and treated it as a delimiter. Now spaces are %20 everywhere and + works as intended. – Brian Nickel Nov 1 at 22:41

I have set the filter to display only the questions that don't have an accepted answer. Yet, occasionally I do see questions that have an accepted answer.

Here's an example:

Just noticed two more.

Here's the filter that I have set:


Update

Looks like "No answers" filter is also not doing what I expect it to do:

  • No answer means no answer with a positive score. – Nog Shine Aug 11 at 6:34
  • 12
    @NogShine That's pretty counter-intuitive. I knew about "Unanswered", meaning that "..having no answer with a positive score or accepted by OP". So this one probably needs to be clarified or reworded. – Nisarg Shah Aug 13 at 5:19

The form doesn't handle large numbers of tags very well. The input field won't resize enough and it does not scroll.

enter image description here

  • 2
    Yeah, I really don't love this either. We're going to see how we can handle large numbers of tags better. – Jon Chan Aug 13 at 16:26

The "see more linked questions…" link when there are more than 10 linked posts results in a "Oops! Something Bad Happened!" error.

This does not occur if I open it in incognito, therefore I'm suspecting that the new custom lists is the culprit.

(You can test it out on one my questions which has 12 linked posts)

  • 1
    Huh. How is this part of the custom question lists? – André Kool Aug 11 at 14:00
  • 1
    @AndréKool, I guess some kind of a weird dependency which is not taken care of in the custom question lists. If I opt-out of CQL, the "see more linked questions" url works, when I opt back in, it doesn't. Let's hope that the dev tells us about it when they fix it. – Bhargav Rao Aug 11 at 14:57
  • My guess would be that this has to do with the "Most links" sorting option. – André Kool Aug 13 at 13:21
  • 8
    The crux of the problem here is that the linked questions page doesn't have its own view; it just reuses the normal questions list (there's perhaps an even more obscure bug caused by this in that you can get live notifications for new questions showing up on that page on some sites). That view now expects an extra bit of data that contains information on all of your customizations... Which of course the linked questions controller doesn't provide. So, boom! – Shog9 Aug 14 at 1:36


The Reset option in the Filter: TAGS is not functioning, if you are adding some tags and click the Reset. But if you are change the Radio button option and click the Reset it will clear the tags.

I have verified the issue in the recent Google Chrome and Mozilla Firefox browsers.

Screenshot for reference:

Reset not functioning

The tag autocomplete isn't working properly (with short imput atleast)

Autocomplete screenshot

  • This is unfortunately working by design. If you try the same thing when asking a question, you get this extended result c# is matching on the cs-file synonym, php is matching on the php-readfile synonym, jQuery on jquery-find and jquery-filter. That's a bigger issue that should probably be its own bug report outside of CQL. – Brian Nickel Nov 1 at 22:47

Why is the My watched tags disabled (when any tag is entered) while the other checkboxes act like actual checkboxes?

Screenshot

  • 3
    The checkbox is disabled when there are any tags already selected (under "TAGS" at the bottom of the filter dropdown). Click "Reset" and it'll be enabled again. – Cai Aug 11 at 14:34
  • 1
    ...assuming Reset works – Draco18s Aug 12 at 18:13
  • 4
    Brown freehand circles! Not kool man! – Nisarg Shah Aug 13 at 8:28
  • You could open the context menu under "More", and pick "Unanswered (My tags)" to select all your tags. – Nisarg Shah Aug 13 at 8:29
  • 3
    @NisargShah I'm colourblind so they are red! – André Kool Aug 13 at 9:32
  • @Cai I know how it works but I'm asking WHY it works that way. Seems weird to me to have different behaviour for a checkbox in a list of checkboxes. – André Kool Aug 13 at 9:33
  • @AndréKool fair enough, that wasn’t obvious from your post. I agree it’s a bit weird and unintuitive – Cai Aug 13 at 9:39
  • @Cai Feel free to improve my post if you can. I'm not very good at describing what I'm asking sometimes. – André Kool Aug 13 at 9:42
  • Why do you expect the My watched tags checkbox to not be disabled? I'm confused why you find this unusual or strange. It seems to me it's behaving exactly the same as the other checkboxes would if they were also disabled. Just because it's the only checkbox that can become disabled isn't bad/unusual/strange. It just means that each checkbox performs a different action (which I would expect to be the case), and some of those actions are sometimes disallowed. – Clonkex Aug 14 at 3:42
  • 2
    That said, I feel it shouldn't be disabled when you put tags in the TAGS box. Instead it should remain enabled, and checking it should disable the TAGS box and ignore any tags you had put in there. That would be more intuitive and self-explanatory. – Clonkex Aug 14 at 3:44
  • Oh, so that's how I can get that checkbox enabled. I wanted to click on it, but I couldn't figure out how to enable it – Justin Aug 14 at 17:16
  • This has been fixed as mentioned in the October update. We had logic to disable "My watched tags" if you were on a tag page. Unfortunately, "My watched tags" is a tag page. – Brian Nickel Nov 1 at 22:50

It seems that when the Unanswered (my tags) button is clicked (see below):

The <code>Unanswered (my tags)</code> button (note the free-hand red circle)

The search bar starts getting filled with the word 'or' when I click on different tabs. For example, after selecting Unanswered (my tags), and then Newest, then Bounties, then Newest, then Bounties and finally Active, the search query changes from:

[python] or [python-2.x] or [python-3.x] or [tkinter]

To:

[python] or or or [python-2.x] or or or [python-3.x] or or or [tkinter]

See below for a gif showing what I mean

enter image description here

Note the repeated word 'or' in both the search bar and just below the All Questions heading

I have a feeling that this is a bug, rather than a feature.

  • This is fixed. There was some doubled up logic in play here. – Brian Nickel Nov 1 at 22:51

When I try to find the bounties which are will be end today, by Filter: Has Bounty, Today and Sort: Bounty ending soon. It returns No questions found. Since there are many bounties are ending today, which I can verify manually.

The same URL in the SO is: https://stackoverflow.com/questions?sort=BountyEndingSoon&filters=Bounty,Today

Today ending bounty

  • 5
    "Today" means created today, so that's why nothing appears. Which I think is confusing... – Nathaniel Aug 10 at 20:04
  • The date filtering is going away since their meaning was confusing in different contexts and they didn't add much value. In each case, it was filtering on questions created within the window, and questions seldom get bounties on their first day. – Brian Nickel Nov 1 at 22:53

If you use "Bounty ending soon" sort option the results will be filtered as if the "Has bounty" was checked. Even if you didn't check it.

Sorting screenshot

(Maybe this sorting option shouldn't be present when you unchecked that filter option)

  • What would you expect to happen if you sort by Bounty ending soon without Has bounty ticked? – Clonkex Aug 14 at 3:34
  • 3
    @Clonkex I would expect it to not be there or be disabled when you havent selected "Has bounty" – André Kool Aug 14 at 8:13
  • Actually, the most logical thing would be to always allow sorting by Bounty ending soon, but not to filter as if Has bounty has been checked. The results should be sorted with all the bounty questions first, followed by any other relevant non-bounty questions (preferably sorted by the previous sort order, or, if that's too difficult to implement and/or too confusing, sorted by either Newest or Recent activity). That would be more consistent than having options disappear/be greyed out depending on what else has been selected, or applying a filter that hasn't been explicitly chosen. – robinCTS Aug 17 at 6:31

The

"Looking for more featured questions? Browse the complete list."

link displayed at the bottom of the Featured tab on Home no longer works.

To reproduce, ensure that the last tab you viewed in /questions is not the Featured tab. Clicking the "complete list" link seems to just bring you to the /questions page with whatever tab you were last on, not the featured list that might be expected from the text.

Similarly, the "complete list of questions" link at the bottom of most of the other Home tabs doesn't work as described, but just uses whatever tab you were last on.

Most popular displays the same list of questions as newest, both if I use Sort -> Most popular (which results in https://meta.stackexchange.com/questions?sort=MostPopular), and if I use Other -> Popular (which results in https://meta.stackexchange.com/questions?tab=Popular)

Tested on both SO and MSE, both on the questions page and on a tag page.

Strangely, on MSE, when filtered on a single tag, the tab popular does return different results, but presumably not the intended results. For example, on The review tag page, I only get 2 questions (1, 2). On SO I just get the same result as the newest tab.

When I'm on the bounties tab stackoverflow.com/TAG?tab=Bounties the filter is on "has bounty" and the sort is on "bounty ending soon".

When I uncheck the has bounty filter I'd expect the sort to revert to newest or recent activity, now it keeps on bounty ending soon and therefore no results are displayed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .