4

With the AdBlock add-on, this is what Stack Exchange sites look like:

adblock enabled

And there are lot of errors in the console, like:

Uncaught ReferenceError: StackExchange is not defined
  at 51978760?noredirect=1:45

There are several resources blocked, for instance:

When AdBlock is disabled, all these resources are loading fine.

closed as off-topic by Won't, Ward, Nathan Tuggy, rene, Sonic the Anonymous WizHog Aug 23 '18 at 21:08

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not appear to be about the software that powers the Stack Exchange network, within the scope defined in the help center." – Won't, Ward, Nathan Tuggy, rene
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    It looks like all CSS and all JavaScript is blocked. What do you expect the SE dev team to do? It is explicit that it needs javascript to have a functioning site. It doesn't offer a gracious fallback. – rene Aug 23 '18 at 7:51
  • A. If they can change anything (file names for example) so the site will works properly. B. They can show a message that the site is not working well with active adblock and if the user wants to full experiment, it will be better for disable it on SO. – Mosh Feu Aug 23 '18 at 7:54
  • 1
    Just exclude *.stackoverflow.com from being blocked by your adblock tool – rene Aug 23 '18 at 8:00
  • 1
    Ya, I know and just did it. I thought about another users that will face this problem and wouldn't think about adblock issue. – Mosh Feu Aug 23 '18 at 8:11
  • there used to be a top banner when you had javascript blocked: meta.stackexchange.com/questions/89433/…. Can you check and edit in which resources failed to load? If the "requires javascript" banner no longer works that might be an unforeseen regression. – rene Aug 23 '18 at 8:14
  • Just did. Thanks! – Mosh Feu Aug 23 '18 at 8:27
  • 1
    If you can whitelist cdn.sstatic.net instead of stackoverflow.com you should be good to go. sstatic.net is an SE owned domain so whitelisting it is considered to be safe, assuming you trust SE. – rene Aug 23 '18 at 8:32
  • If I disable adblock on stackoverflow it's enough for me. Again, what about the other users who wouldn't think about adblock issue? – Mosh Feu Aug 23 '18 at 8:34
  • There are some <noscript> tags that try to inject generic CSS and a div that tells users the site is best used with javascript enabled but those obviously don't work well if there is a partial failure. A front-end dev needs to look into this and decide if it is possible to detect this state. – rene Aug 23 '18 at 8:39
  • There are a lot of options to detect if adblock is enable, for example: detectadblock.com – Mosh Feu Aug 23 '18 at 9:03
13

This is caused by an error in Easylist. See GitHub. All sites with an N anywhere have resources blocked, including cdn.sstatic.net.

It should be fixed now. Make sure to update Easylist to get the solution.

  • Thanks! How can I update Easylist? I don't run it locally so I need to wait until adblock will update it? – Mosh Feu Aug 23 '18 at 10:09
  • 2
    Most ad blockers have a settings page that allows you to do this. I'm not familiar with your specific blocker. If you can't figure it out, you can try asking that on Super User, but it's usually easy. – Erik A Aug 23 '18 at 10:11
  • Just synced and it solved the problem! – Mosh Feu Aug 23 '18 at 10:35
  • 6
    N number of sites were affected by this bug. – Tim Post Aug 23 '18 at 14:14
  • 1
    @MoshFeu An alternative would be: click the ABP icon, choose "Options", go to the "Advanced" tab, and then in the "Filter lists" section click "Update all filter lists". – Andrew Morton Aug 23 '18 at 17:09

Not the answer you're looking for? Browse other questions tagged .