3

When moving around the sites on Stack Exchange using Safari on my iPad (not the Stack Exchange App), I am fine when moving to any site other than SuperUser. When logged in, I can switch sites and stay logged in, but when I switch to Super User I need to log in again.

If I choose not to log in and switch to another site, I am logged in there.

Is there a problem with the login handling for Super User?

If it helps, I log in with a Stack Exchange account, not through Facebook or Google.

Update

After getting fed up with the problem, I took the advice given in the answer below which was to use Chrome, and the problem still exists. The same goes for Firefox. Have I missed something? As you can see from the screenshots below, there are no cookie settings to be found.

Chrome for iOS settings page

settings page

Privacy settings page

privacy settings

Content settings page

content settings

Google app settings page

google app settings

3

I have found a solution to the problem within Safari. I am still at a loss regarding Firefox and Chrome.

On the iPad go to Settings -> Safari -> Privacy and Security

Make sure you have Prevent Cross-Site Tracking turned off

enter image description here

2

Mozilla Support provides information on enabling and disabling tracking cookies at https://support.mozilla.org/en-US/kb/tracking-protection-ios

I tried all the methods mentioned there

and the same problem occurs on my iPad using Firefox for iOS.

It looks like we are okay with Safari though from what you pointed out which was your original aim.

1

This is because Safari blocks all third-party cookies, or cookies from other second-level domains.

As Super User is hosted on a different domain, your login session there is separate from that on sites hosted as subdomains of stackexchange.com.

You'll also face the same problem on other sites that aren't hosted on stackexchange.com, such as Stack Overflow or Ask Ubuntu.

If you find this to be an issue, you can disable third-party cookie blocking in Safari by following the instructions in the other answer, or switch to another iOS browser that does allow third-party cookies, such as Chrome.

  • 1
    "This is because Safari blocks all third-party cookies, or cookies from other second-level domains." This is obviously wrong from what @ChrisRogers has found – Chalmondley Sep 20 '18 at 11:33
  • @Chalmondley That's exactly what happens internally when the "prevent cross-site tracking" option is enabled. It prevents sites from seeing cookies from other sites, i.e. "blocks third-party cookies". – Sonic the Bracketed Hedgehog Sep 20 '18 at 11:42
  • 1
    Yes, but to say that you have to go for Chrome instead implies that there is no alternative as there is no way of changing that. – Chalmondley Sep 20 '18 at 11:49
  • 1
    @Chalmondley Edited my answer. – Sonic the Bracketed Hedgehog Sep 20 '18 at 11:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .