3

In short, if the last action on the post is someone posting an answer, it shows "answered [x] minutes ago PosterName". However, deleting and undeleting a different answer (posted earlier) causes it to switch to "modified [x] minutes ago PosterName", even though post deletion and undeletion do not cause bumping. The last action on the post was answering, so it should continue to show as "answered".

For example, I tested this out in the sandbox:

Answer is posted:

30 seconds later, another answer is deleted (and optionally undeleted; or vice versa probably), changing the label but not bumping it:

The behavior that it should be is:

  • Find the last active post
    • If the last active post is deleted it should say "modified"
    • If the last active post is not deleted and not edited it should say "answered"
    • If the last active post was edited, it should say "modified". No duh.

Here's my original bug report, which you can probably just skip unless you need another example:

I just posted an answer to a question, then left the page without doing anything else. But it says the last action on the page is me modifying something, with the modified link (which shows the last activity) redirecting to a link to my answer, as shown below on the active tab of the home page (it's at the top of the list):

(The other active page, under Questions, also shows this problem.)

I didn't modify the answer after posting (not even during the grace period) nor did I do something else that would cause a "modified" bump (protection, close/reopen votes, add bounty, messing with deletion). There were no deleted answers when this happened. I'm not sure if the problem is related to the question having a bounty on it (by the OP, who is deleted).

None of the other activity on the active page shows this problem. (The "modified 10 minutes ago" on the second question is an edit to an answer.)


Since I first posted this question, another user (named 1006a) posted an answer to the exact same question. For some time the listing read "answered X minutes ago", but now it says "modified X minutes ago" even though it points to the same, unedited answer. However, I noticed that there is now a deleted answer which was last edited before 1006a's answer was posted, but was deleted after it was posted. Now I'm wondering if it has anything to do with deletion.

  • Good luck with drawing any attention to this bug. In the current climate, the devs have other things on their plates. It might get attention if you say whether this bug occurs on the old theme or the new one. – Mari-Lou A Oct 25 '18 at 0:18
  • And it will definitely get a response if this bug can be replicated on Stack Overflow... – Mari-Lou A Oct 25 '18 at 0:20
  • 1
    @Mari-LouA Actually, I just repro'd it here on MSE, so it's not related to the new/old nav thing. Since Stack Overflow doesn't have a sandbox I wouldn't really want to test it out there. – Laurel Oct 25 '18 at 1:03
  • 1
    Good thinking, old chum! It appears it could be a network-wide bug. And if I've learnt one thing on SE Meta, hand-drawn red circles always get high approval ratings, so consider adding a few of those. – Mari-Lou A Oct 25 '18 at 1:08
  • I see it maybe badly, but the fact it dont bump prevent an abuse ? to not have someone that try to bump his question/answer to the top of the 'active' page by using that trick ? – yagmoth555 Oct 25 '18 at 1:26
  • 1
    @yagmoth555 Deleting/undeleting doesn't bump the post by design, I think. I think the problem is that the "modified" action is linked to the wrong user/post. – Laurel Oct 25 '18 at 1:35
  • ah ok! I now understand better the bug – yagmoth555 Oct 25 '18 at 1:38
  • Yes, it should be showing "modified" on the answer that was undeleted (most recently acted upon), not a different answer. That's a bug. – Monica Cellio Oct 25 '18 at 1:43
  • 1
    Not causing a bump doesn't mean that it shouldn't change the status. Deleting does change the status to "modified". – Catija Oct 25 '18 at 1:52
  • @Catija But the link doesn't point to the post that was modified nor the user that did the modification. – Laurel Oct 25 '18 at 2:01
  • That seems to be the case... but that's not what the question here says. The questions list behavior is correct, the question behavior isn't... but both times you deleted and undeleted have identical timestamps... to the second. Does the same thing happen if you actually wait so that the timestamps are different? It's likely that the identical timestamps are part of the problem. – Catija Oct 25 '18 at 2:13
  • @Catija Yes, some time after 1006a's answer was posted, this answer was deleted and it showed "modified [x] minutes ago 1006a". (This is what I was describing at the bottom of my Q here, although the deleted answer was undeleted since I wrote that.) If this makes any sense... – Laurel Oct 25 '18 at 2:26

You must log in to answer this question.

Browse other questions tagged .