I just switched from an iPhone 7 to an iPhone XR (both are on latest iOS version available).

When I try to login into the Stack Exchange app with my Google account it says:

Request failed
Could not perform this request with your account. Please try logging back in. If this persist, let us know on meta.

this happens consistently.

I have 2FA enabled on my Google account if it matters.

Is this a known bug?

  • Try using an application-specific password. Oct 31, 2018 at 18:34
  • 1
    It doesn't allow me to login with an app-specific password, but in any case the login worked just fine on my iPhone 7...
    – Fez Vrasta
    Nov 1, 2018 at 12:55
  • 3
    I have exactly the same problem: I was loggedin on my iPhone X, then I migrated to the iPhone Xs Max... On my iPhone xSMax I had to login via google again. I can pick my google account but afterwads I get the same error.
    – Nabi
    Nov 5, 2018 at 16:15
  • 1
    Same problem with an iPad. Switched from iPad Air to an iPad Pro and the login with Google fails.
    – egreg
    Nov 16, 2018 at 14:36
  • 1
    No action after 20 days. This is very bad.
    – egreg
    Nov 19, 2018 at 12:14
  • The app is not dead it's just a matter of interface authentication. It's useful for getting quick answers.
    – Dor Bar
    Nov 26, 2018 at 11:21
  • @egq not a single bug in the apps was fixed for several years. Nov 27, 2018 at 11:47
  • 2
    @DorBar so how you call an app where its developers not fixing any of its bug, ever? I call it dead. Nov 27, 2018 at 11:47
  • 1
    Yeah, last update was a year ago. It's dead.
    – Dor Bar
    Nov 27, 2018 at 20:50

2 Answers 2


This was fixed a while back.

There was a regression in Google's tokeninfo endpoint that was causing requests to fail server-side. More details at Unable to log in with Google account to the Stack Overflow iOS app (Request failed)


If SE will ever decide to assign a programmer to fix this bug, my advice is to start here: 403 Error - Thats an error. Error: disallowed_useragent


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .