5

When I click the "DOWNLOAD" link on the Winter Bash hat knitting tool, I get this error message:

Safari can’t open the page “blob:https://winterbash2018.stackexchange.com/a0dda976-17cf-4ae3-b012-4658fe7bd012”.

The error is: “The operation couldn’t be completed. (WebKitBlobResource error 1.)” (WebKitBlobResource:1)

browser screen shot with error message

I am using MacOS High Sierra (10.13.6) with most up-to-date Safari browser (12.0.2).

I expected a bitmap (maybe PNG format) to be downloaded. Instead, it seems to be some "blob:" protocol that I haven't seen before (but what do I know of these things).


When right-clicking on the link and selecting "Download Linked File" the link works and the file is downloaded. It looks like Safari just doesn't know how to open the blob: link.

  • 1
    Same here, I was just digging into this to write up a bug report. Nothing in the console, and (from what I can tell) no request is actually made, so no headers to inspect or anything. – Tim Post Dec 12 '18 at 17:11
  • @TimPost: Indeed, it looks like a link that the browser doesn't know what to do with. – Cris Luengo Dec 12 '18 at 17:12
  • blob: stands for binary large object, in other words, file data, which might be a bitmap or a png. See superuser.com/questions/948738/… for more info about blob links, it surprises me that Safari apparently doesn't support them – Erik A Dec 12 '18 at 17:13
  • 1
    For what it's worth, downloading is working in Safari Technology Preview, so we're probably hitting a bug/limitation that'll get fixed in 12.1. – Brian Nickel Dec 12 '18 at 17:31
  • document.getElementById('ke-download-link').removeAttribute('target') makes it work for me. Filing a PR. – Brian Nickel Dec 12 '18 at 18:12
  • My first thought was: Who on earth would go on a safari with a knitted hat? It’s much too warm. – Wrzlprmft Dec 13 '18 at 6:40
4

This is fixed for Safari on macOS.

iconic "hello" knit

There is a bug in Safari where opening a blob in a new tab will produce the error you observed. Funny enough, the reason we have target is to mitigate the fact that IE doesn't support the download attribute, so helping one browser hurt another.

This fix doesn't carry over to Mobile Safari unfortunately, because (as I only found out after pushing) it doesn't support the download attribute or opening blobs in a new tab. ¯\_(ツ)_/¯ Not sure what we'd want to do there, because we also don't want to navigate.

  • I have same issue, I tried with all combination of having target or download attribute and still same error, any idea? – RezaRahmati Mar 13 at 17:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .