7

Fol­low­ing up on yes­ter­day’s some­what re­lated bug re­port, I have to­day dis­cov­ered that the User Ac­tiv­ity page on the Span­ish SO site has var­i­ous bugs in its plu­ral­iza­tion:

ES demo of bug in singular votes cast erroneously plural ES demo of bug in singular useful reports erroneously plural

No­tice how I’ve the two red cir­cles are around some­thing that says there’s only one of it nu­mer­i­cally (digit 1) but whose cor­re­spond­ing text, be­ing in the plu­ral, in­di­cates that there are any­thing but one.

When you only have one of them, you cannot use the plural. Those should both be in the sin­gu­lar:

  • 1 voto emitido
  • 1 reporte útil

I do not check to see whe­ther the edit count ­suf­fers from the same bug, but I wouldn’t be sur­prised if it did.

How does this hap­pen?

Very cu­ri­ously, a quick glance at the cor­re­spond­ing User Ac­tiv­ity page on the Por­tuguese SO site sug­gests that it does not suf­fer from this bug!

PT demo of okness in singular PT demo of okness in plural

It seems that some in­ter­na­tion­al­ized sites have nu­meric bugs, but oth­ers do not: how does that hap­pen? Isn't the code all the same? Are you some­how in­cor­rectly mark­ing things sin­gu­lar-ver­sus-plu­ral?

Are you per­haps crowd­sourc­ing out for just one trans­la­tion for that slot when you need more than one?

Or could it be that when you do not have both slots filled get stuck de­lib­er­ately us­ing one that’s nu­mer­i­cally in­ap­pro­pri­ate at times?

  • 2
    Thank you for the report! Could you please check those strings on Traducir.win? I looked on SOru and everything is fine. – Nicolas Chabanovsky Jan 2 at 11:43
  • 1
    @NicolasChabanovsky Could you please provide a link to that so I can check it? I forget where it lives. – tchrist Jan 2 at 11:51
  • 2
    The app should live on traducir.win. The key for flags "bd494a943365073fe43dd874c93cc686", for votes (probably) "3c871f5787a2ac522436a205c70874f0". – Nicolas Chabanovsky Jan 2 at 12:05
  • 2
    I have suggested changes in traducir.win to fix this translation bug in the keys given by @Nicolas – fedorqui Jan 2 at 21:32
  • 2
    @fedorqui Thank you! I've imported strings to the DB. Let's see if it fixes the problem. – Nicolas Chabanovsky Jan 3 at 8:22

You must log in to answer this question.

Browse other questions tagged .