24

When you search on any of the SE network sites, with a tag (so that a description is shown); it shows the tag info content box, with the highlight-search-term span elements.

For eg. I searched [c#] IHttpFilter on stack overflow; [controllers] mess on [gaming.SE]; and the results are as shown:

c# thing

gmaing.SE


Notice the <span class='search-highlight'> boxes around searched tag terms.

  • 2
    I noticed the same issue (here is a screenshot) using Firefox 61.0.1 on Ubuntu. Yesterday (10-jan-2019) I noticed it for the first time. – Ralf Jan 11 at 9:28
  • 3
    Meta.SO cross-site post: Search highlight html not rendered when using advanced search – Xufox Jan 15 at 8:36
  • 3
    Meta.CR cross-site post – Mast Jan 17 at 15:31
  • 2
    Also happening on U&L (e.g.) – Jeff Schaller Jan 26 at 14:18
  • 1
    Reproduced in both the links, along with pretty much every other tag on SO (haven't checked other sites, but it at least seems fine on meta, and weirdly in a different FF container). – Asuna Jan 31 at 15:50
6
+50

This snuck in with the fix for a bunch of weird truncation and escaping bugs a couple of weeks back.

Given there's no particularly good reason to highlight search terms in the tag excerpts to begin with, the sensible fix here is to... Stop adding them, and sidestep the whole issue.

Nick put this fix in today, and it should be live everywhere now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .