Since some time (1 to 2 month), this site is no longer loading on my computer at work.

I tried different browsers (Firefox 3.5.5 and Internet Explorer 7).

The error seems to be in the scripts loaded from http://ajax.googleapis.com. Loading them directly results in getting some code, but the browser will continue trying to load more.

Stack Overflow is not displayed, until Google times out.

My company is using "Websense" to block "unwanted" content.

  • @PeterMortensen this was bumped by an answer that is now deleted, not the automatic bump process, which leaves a clear message in the revisions. – Shadow Wizard Wearing Mask V2 Feb 10 '19 at 13:39

Sounds like your company blocks the Google-hosted jQuery library.

You'll need to talk to your administrators and see if you can get that unblocked.

  • More companies seem to block this than we thought :) RE: Who blocks google anyways! – RSolberg Dec 8 '09 at 16:52
  • @Chester: Stupid, Paranoid People. But they block all sorts of stuff; all you really need to do is ask, "do you filter your users' web browsing?" and if the answer is "yes" then expect things to break at random. – Shog9 Dec 8 '09 at 16:58

The site is working good, with 3.5.5 and Internet Explorer 7. It works with or without ad-blocking software.

The problem is probably with Websense...


The Firefox extension Decentraleyes, created in 2015, replaces CDN resources with local ones. I never tried it myself, but it looks promising according to the reviews.

You must log in to answer this question.