16

For some reasons (HNQ) I stumbled upon this question. I scrolled down, read through the answers and then I saw that there was no answer field:

Oh no? What is going on here?

This was strange, because the question seemed not to be closed, locked or protected. I reloaded the page and the issue persisted. Then I looked at the revision history and saw that the question was protected:

The revision history says: This question is protected

Now normally on protected questions I see a yellow banner either on the top or at the bottom of the page. So I went looking. I found these two questions:

Both questions are protected (as one can see from the revision history). For the first question (the meta one) I see the protection banner directly below the question.

Yes! A protection banner

On the latter question I saw nothing, so .

This is a bug. I can't answer a protected question due to low rep AND I don't see that it is protected.

I think this may be related to some clean-up work being done. Please revert this change.


Edit: As Shog9 noted in a comment, the system seems to show the wrong banners at the bottom position. This can be reproduced by looking at this question in incognito mode:

Ouch! Wrong banners shown below question

  • It's definitely by design that it's not at the top when you don't have enough rep to answer but it should be at the bottom to explain why there's no answer field. – Catija Jan 26 at 16:23
  • 1
    @Catija yes I know, this is what I call a bug. Pretty sure somebody thought Do we need this line? No it can probably be removed and then: this. – MEE is Johann Gambolputty ... Jan 26 at 16:31
  • ... right. I'm supporting your statement because someone downvoted and I'm not sure why. – Catija Jan 26 at 16:33
  • @Catija I wondered about this too, maybe somebody didn't like the original version of the title. (too clickbaity, punny...) – MEE is Johann Gambolputty ... Jan 26 at 16:34
  • 1
    Good catch! The line is still there though - it's just rendering the wrong banners now. Open this link in incognito – Shog9 Jan 26 at 17:10
  • @Shog9 Ouch; added to the question – MEE is Johann Gambolputty ... Jan 26 at 17:18
4

This should be fixed now. The root cause was some work done to reduce overhead on page loads: cruft that'd built up over the years. The "special status" banners for questions have to be identified, prioritized and rendered fairly quickly as they're shown to almost everyone.

Unfortunately, this work ended up papering over one of those annoying exceptional cases: the Protected banner is shown at the bottom of the page (in lieu of the answer form) for folks who can't answer protected questions. This was formerly accomplished by triggering the banner rendering twice, once with the carefully curated list of special statuses, and then again - for low-rep / anonymous users only - with a list containing just the Protected status; after the change, it got called twice with the same parameters.

Now we're back to doing it the old way in spirit, but instead of generating lists on the fly they're populated once. Also, since it's readily available... We can check to ensure that there aren't any other, more important statuses already being displayed before jamming that Protected notice at the bottom - this takes care of a long-time annoyance wherein the Protected banner would tell people they needed 10 reputation to answer... Even if the question was also closed and locked.

Big thanks to Adam Lear for digging into this & working up a fix!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .