15

This question already has an answer here:

Previous posts:

After a lackluster December update, I'm happy to report that Custom Question Lists Phase 2 (saving) has shipped!

What's shipped?

If you are participating in the Custom Question List alpha (by checking a box on your profile and waiting), you'll see a new section in the "More" dropdown:

Screenshot showing "Custom Views" in the "More" menu

Clicking the + button launch a dialog with the same options as the Filter and Sort options giving you the ability to save the view.

Screenshot of custom view dialog

Once configured and saved, the view will be quickly accessible and configurable from the "More" menu:

Screenshot of the "More" menu with two saved question lists

Please give it a try. If you have any questions, bugs, or feedback, you can reply to this post directly or add a new question with the tag.

What's next?

Phase 3 of this project is to add more utility to these saved lists, adding them to the main left navigation and adding indicators for new content.

We've already made significant progress on this front, our production Tag Server is already set up to send back content notifications and I have a version of the web app running locally. It still needs to go through architecture review, get a design treatment, and get a healthy dose of performance testing and other scrutiny, but the end is near.

marked as duplicate by Brian Nickel May 6 at 21:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Are the "Filter" and "Sort" dropdowns on the right side supposed to be independent of the custom question list? When I create a custom view and then change the filter or sort setting, it creates a new "unsaved" custom view. I assumed it would just apply the sort or filter to my existing view. – Kodos Johnson Jan 31 at 0:10
  • @KodosJohnson They're independent of the question list. Changing them moves you to a new list with those settings. Can you add your feedback as an answer and I'll raise it to our designers to look at the UX? – Brian Nickel Jan 31 at 0:19
  • Also, enabling this doesn't mean you necessarily have to answer more questions, right? – grooveplex Feb 1 at 17:47
5

There is a plural issue in the custom view title character validation.
The title is allowing 32 characters, if I'm trying to enter the 33rd character it showing the validation message as "Title is 1 characters too long." It is supposed to be "Title is 1 character too long."

Edit custom view

  • 1
    This will be fixed in the next build. Plurals a managed by our translation system and I forgot to add the English-language definition for the one case. – Brian Nickel Jan 31 at 16:25
5

OoOoh new stuff! Unfortunately, I've had it for five minutes and broke it a little.

I added [regex], then I tried to add [regex*] as a wildcard match (pressing enter to add it) and it didn't work, instead adding a second regex tag, creating a view like this:

The other nav (RIP) let me use wildcards, so this one should too.

  • 13
    Now you have two problems. – Nathan Tuggy Jan 30 at 23:04
  • This is fixed. There were just some UI rules that needed tweaking. That said, regex is the only tag to match /regex*/ so in a sense was matching a wildcard. – Brian Nickel Jan 31 at 21:39
  • 2
    @BrianNickel It’s on Stack Overflow so it matches a number of tags. – Laurel Jan 31 at 22:45
5

Are the "Filter" and "Sort" dropdowns on the right side supposed to be independent of the custom question list? When I create a custom view and then change the filter or sort setting, it creates a new "unsaved" custom view. I assumed it would just apply the sort or filter to my existing view.

  • We redid the UI in way that should address this problem. Those buttons are gone, replaced with a more unified UI. – Brian Nickel May 6 at 22:24
2

The new custom view title is allowing 32 characters length. If we are utilizing the full length in the title, the Filter and Sort are displaying the next line.

With less number of characters in title:

Less length title

With 32 characters in title:

32 char title

The same design issue happened, when less number of characters title with Sort: Bounty ending soon option selected.

2

When I am viewing a custom question list, I am getting a notification saying

X questions with new activity

But when I click on the notification, it shows questions that don't match my filters. Shouldn't new questions match my filters? Or at least don't show notifications at all.

I experienced this at the following URL:

https://stackoverflow.com/questions/tagged/php?sort=Newest&filters=NoAnswers,Bounty&edited=true

I updated the filter to check for questions tagged PHP and I checked the "Has bounty" checkbox. But new questions are showing up without bounties.

  • Can you share the URL? – Brian Nickel May 6 at 22:47
  • @BrianNickel stackoverflow.com/questions/tagged/…. I have php tag with "Has Bounty" checked. New php questions show up but they don't have bounties. – Kodos Johnson May 6 at 22:52
  • 1
    I have a fix for this in code review. Basically we weren't exposing enough information for the page to apply filters to the new questions. – Brian Nickel May 7 at 21:01
  • 1
    This is fixed now. The realtime banner is aware of those filters and is capable of handling things like php -phpmyadmin and php or javascript ajax – Brian Nickel May 29 at 22:39
0

While scrolling the page when the top bar is sticky, the opened custom view dialog box is overlapped with the top bar.

Since the other options, Filter, Sort are hide under the top bar while scrolling, for the uniformity the custom view dialog box also may hide under the top bar.

Custom view

GIF for the same:

Custom view - GIF

0

In the Filter option, if I select any tag with the The following tags option textbox and click out of the dialog box it closed the dialog box and the selected tag's related questions are loaded properly.

Again if I want to filter any other specific tag, I click on the Reset option which is located above the textbox and select any other tag, and clicked out of the dialog box, the newly selected tag's related questions are not loaded, instead it stayed with the previous selected tag. Seems in the second time the call is not triggered.

GIF for the same:

Reset and select tag

  • This has been fixed. There's some logic in place so it doesn't navigate every time the filter closes. Despite having written comparison the methods myself, I was calling them the wrong way and comparing the wrong things. – Brian Nickel Feb 12 at 21:23

Not the answer you're looking for? Browse other questions tagged .