3

When visiting the questions page, e.g. here on meta https://meta.stackexchange.com/questions the previously visited tab is no longer selected by default.

Previously it would automatically show the active tab if this had been the last tab I used in my previous visit. Now it seems that no tab is selected by default.

enter image description here

I experience the problem both with firefox and opera

  • I always thought that the root domain was Active and the "questions" link was Newest? It's supposed to remember what you were on? – TheWanderer Jan 30 at 23:23
  • @TheWanderer The root domain is missing the preview of the post body (the first few lines) and the user icon. These things are only visible in the questions->active tab – user237989 Jan 30 at 23:25
  • 1
    This regression is probably my fault. I'm checking on it. – Brian Nickel Jan 30 at 23:28
6

This is fixed.

After refactoring some code, I accidentally ended up with code that functioned like this:

if (!Enum.TryParse(sort, true, out ListViewData.Sorts lSort))
{
    actualSort = GetQuestionSortOrder(lSort, CurrentUser);
}

This code executed used the extracted value of lSort even though parsing failed. Instead of passing in null which would have fetched the saved value, I was passing default(ListViewData.Sorts) which is of no use to anybody.

Incidentally, I didn't make the same mistake in tagged question lists, so /questions/tagged/support is working like it should. There's something to be said for modern functions that return Nullable<T> rather than using out parameters[1].


[1] I'm old enough to remember when TryFoo(out) was the modern replacement for try { Foo() }

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .