3

In the stackexchange.com - moderators page, there is a strange issue with the search text.

When I try with "ask" in the search box, it is displaying the matched entries such as Ask Different, Ask Patents, Ask Ubuntu and a partial match with a user.

But when I try with "stack", I'm expecting Stack Overflow and other Stack Overflow international sites. It is not displaying the expected result, again I'm adding space and o along with "stack", like "stack o", now it is displaying the expected result.

GIF for the same:

Search string

I didn't see any error in console and network tab. What is the cause for the issue?

  • 2
    I'd guess it's because all of the sites are <something> Stack Exchange. – Taryn Jan 31 at 14:37
  • 2
    Yeah, it seems to take into account site URLs as well: Try cooking, or gaming: cooking gives Seasoned Advice, gaming gives Arqade, because their URLs mention cooking and gaming instead of their site name. As most URLs contain some form of 'stack', that explains the big list there. – Tinkeringbell Jan 31 at 14:39
  • 2
    The interesting side note with Arqade and Seasoned Advice is that both of those are owned domains, they just redirect. So arqade.com and seasonedadvice.com are valid SE URLs. This is the case with a few other sites, too. – Catija Jan 31 at 14:43
5

This isn't a bug, it's . The code to search looks for any of the following:

  • Site name
  • URL or Host Address
  • Moderator Name

Since stack is a part of all of the URLs for most of the sites on the network it is filtering as expected.

  • 1
    Just FYI, the code that inits the search starts this way (around line 31: var searchData = {"640":"3d printing stack exchange 3dprinting.stackexchange.com greenonline starwind0 tbm0115", ...) – MEE was the missing bracket Jan 31 at 15:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .