I've seen a number of reports of special characters breaking links, some of which seem to get fixes, others seem to be tagged "status-by-design". I didn't see any indicating that the $ sign wasn't working so I thought I'd report it. I tried to link to:


But the link does not appear as a link either in the editor or in the completed question. I fixed it by using TinyURL to proxy the link and pasting in the TinyURL.

2 Answers 2


See if you can safely remove the dollar sign ($)


The dollar sign is a special character (and apparently hasn't been taken in with the automatic SO linkifier).

If you wanted (or could be bothered) you can also encode to its hex equivalent (%24):


  • Never even occurred to me to remove it. I'd been hit with something similar before so I immediately went to my fallback of TinyURL.
    – tvanfosson
    Dec 9, 2009 at 16:10

Must be escaped; nice that it happens to be optional in this case.

Edit: Note that as of recently, problem characters will automatically be escaped when entering a link via the button (or Ctrl-L).

  • 4
    The RFC for URLs says that this character is one that does NOT need to be escaped, like the character used for escaping, or pluses. Therefore, breaking your URL parsing on a dollar sign is a bug. ietf.org/rfc/rfc1738.txt Feb 3, 2011 at 9:38
  • @DanGrossman: This has nothing to do with RFC. We're talking about auto -recognizing links in text; you need some trade-offs there.
    – balpha StaffMod
    Mar 11, 2011 at 14:00
  • Is there any way we could parse all questions for links, and automatically escape the $? I came across this in another post again, and removing the $ is not a working solution, although it looks like escaping it manually does work (in the browser URL field that is, didn't make the change to the question). Nov 26, 2013 at 15:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .