I'm unable to get rid of a filter that goes by the name of "My Filter". This is the default name you get when you click on New Filter. There's a clickable "Delete this filter", which leads to a confirmation question on whether you really want to delete it. Clicking "Yes" leads you back to the "New Filter" Screen, with a new filter named "My Filter".

I don't know whether this is the same filter I was just trying to get rid of, or whether it got rid of the old one, and now is making a new one with the same old name. Either way, I'm stuck.

  • 7
    I can reproduce this, both with "My Filter" and "My Filter (2)". I also tried deleting another filter (one that was for a now-burninated tag) which deleted it but created "My Filter (3)". It is clearly deleting and creating a new filter, since the number in the URL changes. – Laurel Mar 3 '19 at 21:14
  • 3
    Same for me - deleting a filter does not work. I now have "My Filter" and "My Filter (2)". – Mark Apr 12 '19 at 4:01
  • 1
    @Mark - I'll see your "My Filter (2)" and raise you with a "My Filter (3)" :( – Lieven Keersmaekers Apr 28 '19 at 10:23
  • 1
    And eventually, we'll get to "My Filter (1023)". – Walter Mitty Apr 28 '19 at 21:00
  • 3
    2 months and no acknowledgement this bug exists! 9 upvotes so far. Is there another place to report issues? I added the support tag, bug tag already here. – Mark May 17 '19 at 17:19
  • 1
    It's even older, I originally reported it in October 2018. – Glorfindel May 17 '19 at 18:59
  • @Mark see my post about the (counterproductive and countersense) bugs page – Mari-Lou A Jul 2 '19 at 5:14
  • Is there a workaround where you can remove ALL of your filters, including the good ones, and start over with a clean slate? – Walter Mitty Jul 2 '19 at 12:48
  • Hard to believe something so basic to user experience just sits unfixed for so long...sigh. – Mark Dec 3 '19 at 19:06
  • Is there anybody who can fix this aware of the problem? – Walter Mitty Feb 25 at 1:45
  • I have the same problem. Bueller? – dave_59 Mar 28 at 21:06
  • 1
    Please finally fix this. – Gas May 13 at 17:19

Adding details in hopes of getting developer attention.

Reproducing the issue from a clean state.

I believe this may be how to reproduce this issue. I can't verify, because I'm already in the broken state.

  1. Start with at least 1 existing, valid filter (with tags and everything).
  2. Click New Filter.
  3. Instead of finishing that filter, click on the existing, valid filter.
  4. Delete the existing, valid filter.
  5. There should be a My Filter in the reloaded page, even though you never finished creating it. Try to delete My Filter now.
  6. This might be what spawns My Filter (2). (Not as sure about this part.)

Reproducing the issue from the broken state.

However one gets to the broken state, one can easily keep reproducing more and more My Filters simply by clicking New Filter while viewing an existing, valid filter.

enter image description here

Does finishing the creation of those filters allow them to be deleted? (No.)

These are screenshots from before I created a bunch of My Filters. This is what you see when looking at My Filter.

enter image description here

If we finish creating the filter, can we delete it? Let's make it into a filter...

enter image description here

Clicking "Save Changes"...

enter image description here

Clicking "edit" and "delete this filter"...

enter image description here

Huh? The page reloads and My Filter is back.

enter image description here

I've also tried finishing the creation of all the My Filters, in case having any unfinished filter was causing the issue. No luck.

| improve this answer | |
  • This is very helpful. I hope a developer drops in. – Walter Mitty Jul 2 '19 at 12:49
  • 8
    can confirm bug still exists in 2020 – Samuel Liew Feb 2 at 13:59
  • 2
    Huh.... still not solved???? Why dont you fix this issue!!! – Gas May 13 at 17:14
  • Let's be nice. SO does a lot of hard work for little appreciation. If I were a project manager, this would be at the bottom of the list too. If you wanna never use SO again because of this issue... by all means. – Andrew Cheong Jun 24 at 13:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .