5

I recently answered a question on Stack Overflow where I included a link to a Wolfram Alpha computation. In the editor, I write the link as:

[wolfram alpha](https://www.wolframalpha.com/input/?i=sum+from+k%3D3+to+v+of+(v%5E2+%2F+2)+%2F+((v-k)%5E2+*+k)

-and it displays fine. The preview replaces the URL with the text wolfram alpha. When I submitted it, the answer itself shows the literal text:

[wolfram alpha](https://www.wolframalpha.com/input/?i=sum+from+k%3D3+to+v+of+(v%5E2+%2F+2)+%2F+((v-k)%5E2+*+k)

in its formatted state. I suppose this is due to the parenthesis in the URL, but when I added an extra parenthesis, it rendered as

wolfram alpha)

displaying that extra parenthesis. Regardless, this discrepancy between the editor and displaying the answer itself should be considered a bug in my opinion.

For good measure, lets see how the URL to [wolfram alpha](https://www.wolframalpha.com/input/?i=sum+from+k%3D3+to+v+of+(v%5E2+%2F+2)+%2F+((v-k)%5E2+*+k) behaves here (its displaying fine in the editor, as per the below screenshot):

enter image description here

Here's a go at it with the extra parenthesis:

wolfram alpha

Here's how that looks like in the editor:

enter image description here

  • I am running Firefox Quantum 65.0.1 (64-bit) on Ubuntu 16.04 LTS – Dillon Davis Mar 10 at 21:58
  • 2
    The screenshots are from the editor. I can reproduce; it doesn't appear to be browser-specific. – Sonic the Anonymous Hedgehog Mar 10 at 21:59
  • @SonictheWizardWerehog my mistake. I've retracted my comment. I'll leave my system information though just in case there are issues reproducing it for whatever reason. – Dillon Davis Mar 10 at 22:01

You must log in to answer this question.

Browse other questions tagged .