13

I've just seen that one of my questions has the tag [reactjs]. Now, that question is not about React-JS, and I doubt anyone would add that tag deliberately, so I guessed someone (perhaps even me) added it by mistake.

But when I try to edit the tags, [reactjs] is not in the list of tags. And saving that "edit" does not remove [reactjs] from the question.

  • 3
    "Fixed" by adding a dummy tag and removing it right away. Something caused the "bad" tag to be added only to the static "Tags" field of Posts table, but not in the other tables storing the actual tags, or something like that. Anyway, something super weird and super rare, which can be easily "fixed" so no need to panic. – Shadow The Curly Braced Wizard Mar 26 at 13:34
  • Similar weirdness, but probably not actually a dupe: meta.stackexchange.com/questions/140972/… – Rob Mar 26 at 23:46
12

Looks like that at some point between the edit in Aug 6 '18 and today, the tag was added by mistake to the question, likely as result of some weird and very rare database glitch.

The tag can be killed by simple retagging: adding some dummy tag then removing it right away will remove the "bad" tag as well, and leave a "[Edit removed during grace period]" revision.

Since it can't be reproduced and doesn't cause actual harm, it's not a big deal, just do the above when spotting such cases and order shall prevail. :)

  • 4
    This question was used as a First Posts audit. I can only guess faking the audit added the tag erroneously. I vaguely recall another bug report about that but don't remember. – animuson Mar 26 at 15:09
  • @animuson oh, that makes some sense then, thanks. :) – Shadow The Curly Braced Wizard Mar 26 at 15:14
  • 1
    @animuson There's another bug report reporting a similar thing. – Sonic the Bracketed Hedgehog Mar 26 at 16:04
  • 1
    @Sonic That one is very likely an oddity with the migration from HashCode given they weren't a part of the network when that question was asked, and the question definitely did have that tag on it when asked (the revision history shows it there on the initial revision). – animuson Mar 26 at 16:09
  • 3
    This would be the master report for that bug @animuson. Jarrod cleaned up some of the more severe damage caused there, but apparently tags got through. Wait... That was fixed years before the question above was posted; that's fishy... – Shog9 Mar 26 at 17:38
  • 1
    Ok, so... After digging into this further, I'm less sure that it has anything to do with audits; I was only able to find 7 other examples of this on Stack Overflow, and only one of those ever had an audit generated for it - it's a plausible theory there, except... the tag was apparently introduced after the last tag edit and before the last audit. – Shog9 Mar 27 at 4:18
  • @Shog so my assumption of "weird temp db glitch" still apply? :) – Shadow The Curly Braced Wizard Mar 27 at 12:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .