101

Every time I open a question I get this oh so funny 90s feel with scrollers and whatnots. In every question I need to click it off. The button seems to only work for the specific page I load; loading a different page shows the theme again.

Is this an attempt to keep people from using the site for a few days or how do I tell you "please never ever do anything like this if you want me to keep contributing here"? Yes I have no sense of humor if this is an attempt at that.

How do I turn off "time travel" (also known as "back to the future") mode off permanently, on all questions, and preferably network-wide?

  • 46
    This honestly annoys me too. Disabling it with the button only disables it until a new question is opened, at which point it's re-enabled. This cannot be by design, but they did so last year too. Incredibly obnoxious – Olivia Mar 31 at 10:18
  • 4
    It's just one extra click, lighten up folks. – Mari-Lou A Mar 31 at 10:20
  • 34
    @Mari-LouA per tab. I'm highly active in moderation on SO and I probably open hundreds of tabs on SO per day, aside coding research and meta digging. That's hundreds of clicks and completely unnecessary use of time and bandwidth – Olivia Mar 31 at 10:22
  • 7
    It also makes the site run extremely slow on my computer. – Sonic the Anonymous Hedgehog Mar 31 at 10:23
  • 6
    +1, I actually have an opposite request: I'm absolutely OK with the unicorns, I need a way to disable this annoying "Back to the future" pop-up on every page. – default locale Mar 31 at 10:24
  • 14
    @Mari-LouA So you only look at one question per day? Lucky you. I happen to look a multitude every day. That's how we operate here. If it were a single click I wouldn't complain. – Sami Kuhmonen Mar 31 at 10:24
  • 1
    A simlar request is on MSO here. – Wai Ha Lee Mar 31 at 10:25
  • 15
    It's controlled by a cookie named tm2019 but it's a separate cookie for each question. Smells like a programming error ... – Glorfindel Mar 31 at 10:31
  • 13
    I guess this is the kind of thing that MS wanted to avoid when they prohibited April fools jokes. – skandigraun Mar 31 at 10:39
  • 1
    @Glorfindel lack of testing. – Shadow The Dragon Wizard Mar 31 at 10:39
  • 12
    Sorry y'all. It's a bug. We're working on a fix. Thanks for reporting it. We'll get this adjusted shortly. – Catija Mar 31 at 10:45
  • 1
    This should be fixed now. – Wai Ha Lee Mar 31 at 11:03
  • 2
    Shame a really good answer got deleted especially for its coverage of problems experienced by users with autism. – QHarr Mar 31 at 11:06
  • 3
  • 2
    @QHarr as I commented there, the issues raised in it were interesting, but it wasn't answering the question of 'how to turn this off entirely'. I forgot to say this in that comment, but I'd love to see this have it's own question, and it now has – Tinkeringbell Mar 31 at 11:14
11

I've built a userscript to disable Time Travel mode on all sites, which you can install from here. The updated version (0.3) does not interfere with the fix rolled out by the developers. Thanks to @Makyen, @SonictheWizardWerehog and indirectly to @Bergi for your contributions.

// ==UserScript==
// @name        Disable Stack Exchange Time Travel Mode
// @namespace   https://github.com/Glorfindel83/
// @description Disables Time Travel Mode (April Fools 2019) on all Stack Exchange sites
// @author      Glorfindel
// @updateURL   https://raw.githubusercontent.com/Glorfindel83/SE-Userscripts/master/disable-time-travel-mode/disable-time-travel-mode.user.js
// @downloadURL https://raw.githubusercontent.com/Glorfindel83/SE-Userscripts/master/disable-time-travel-mode/disable-time-travel-mode.user.js
// @match       *://*.stackexchange.com/*
// @match       *://*.stackoverflow.com/*
// @match       *://*.superuser.com/*
// @match       *://*.serverfault.com/*
// @match       *://*.askubuntu.com/*
// @match       *://*.stackapps.com/*
// @match       *://*.mathoverflow.net/*
// @exclude     *://api.stackexchange.com/*
// @exclude     *://blog.*.com/*
// @exclude     *://chat.*.com/*
// @exclude     *://data.stackexchange.com/*
// @exclude     *://elections.stackexchange.com/*
// @exclude     *://openid.stackexchange.com/*
// @exclude     *://stackexchange.com/*
// @run-at      document-start
// @grant       none
// @version     0.3
// ==/UserScript==

(function () {
  "use strict";
  if (Date.now() < 1554335999000) {
    //Don't do anything if April Fools 2019 is past.
    if (document.cookie.indexOf('glorObeyUserPref') === -1 && (document.cookie.indexOf('tm2019') === -1 || document.cookie.indexOf('tm2019d') === -1)) {
      //We only want to set these once, so the user can turn the 2019 April Fools theme on for a site, if they want.
      //Using a cookie for our own flag automatically cleans up for us after April Fools Day.
      document.cookie = 'glorObeyUserPref=1;path=/;expires=Wed, 03 Apr 2019 23:59:59 GMT';
      document.cookie = 'tm2019=1;path=/;expires=Wed, 03 Apr 2019 23:59:59 GMT';
      document.cookie = 'tm2019d=1;path=/;expires=Wed, 03 Apr 2019 23:59:59 GMT';
      window.location.reload(false);
    }
  }
})()
  • So many duplicates here... – iBug Mar 31 at 11:01
  • 2
    I assume it will end when the last timezone on Earth reaches April 2nd, so 2019-04-02 12:00 UTC give or take an hour. – Glorfindel Mar 31 at 14:50
  • 1
    Thank you for also including the explanation, you're a gentleman. If ever there is a mod election on Meta, you have my vote! – Mari-Lou A Mar 31 at 14:58
  • You're welcome, and thank you for the compliment. – Glorfindel Mar 31 at 16:16
21

Your on/off preference should persist across each site now. Happy time traveling! :)

  • 18
    Why not across the whole network? – ColeValleyGirl Mar 31 at 11:06
  • 6
    Nope. Can't bring it back on. Once you click the "Time Travel", you can't ever see it again. So.. I'm afraid the answer is wrong. That said, kudos for a cool and original prank. :) – Shadow The Dragon Wizard Mar 31 at 11:06
  • 1
    @ShadowWizard I suppose clearing the cookie should work. Not tested, though – iBug Mar 31 at 11:10
  • 1
    @MetaBugWizard nah, can't be bothered for it. If that's on purpose I'm fine with it, just expected it to be bit.... better, UX-wise. (i.e. having the icon toggle it on/off, not just off as it now does.) – Shadow The Dragon Wizard Mar 31 at 11:17
  • 2
    @ShadowWizard Seems to be fixed now (you can toggle). :) – Blue Mar 31 at 11:59
  • 3
    It’s not working for me at least, and I’ve had surgery while awake that was more fun than this ‘joke’, sorry 😐 – Rob Moir Mar 31 at 13:07
  • 8
    Can we get a way to disable it across the whole network? It was fun for a few minutes, but I'm ready to move on. Unfortunately this has to be done per-site, which can be a lot of sites for active users... – Cornstalks Mar 31 at 14:57
  • Jumping on the "we need a network-wide disable flag" bandwagon. This was funny and I enjoyed it for about 30 seconds. I'd like to unsubscribe from this newsletter, please. – MikeTheLiar Apr 1 at 20:15
14

This answer previously contained a line of code that would disable this feature for a given site, but that is no longer necessary as SE has changed it to affect all pages rather than just the one.

However, you can install this user script to remove it from all sites, network-wide, permanently, in your browser. As written, this script will permanently disable it - simply disabling it or clicking the time icon in the top bar will not re-enable it. To re-enable it, you must disable this script and clear your cookies.

Credit goes to Bergi for helping me find this.

  • 4
    Here you go (direct install link - source). Should work network-wide. – Olivia Mar 31 at 10:58
  • Heh, I was just in the process of doing that... – Glorfindel Mar 31 at 11:01
  • As was I...see edit. – Sonic the Anonymous Hedgehog Mar 31 at 11:05
  • It didn't trigger on Quantum Computing... – John Dvorak Mar 31 at 11:16
  • Or maybe it did, but it still needed manual refresh, which is still bad. I suppose that running the cookie-setter together with my clock-clicker is the best we have so far. – John Dvorak Mar 31 at 11:17
  • @JohnDvorak I've updated the script; can you please test on another site you haven't browsed with the script enabled and see if it still requires a refresh to disable? – Sonic the Anonymous Hedgehog Mar 31 at 11:18
  • Which one? The link in your answer still throws me a script that only sets a cookie. – John Dvorak Mar 31 at 11:20
  • @JohnDvorak It doesn't prompt you to update the script? It does for me. (The change I made is supposed to make the script execute before the page loads, so that by the time the page loads the cookie will already be loaded; the previous version didn't load it until the page had already began to load, so the cookie wasn't present on first load, but only on second load.) – Sonic the Anonymous Hedgehog Mar 31 at 11:23
  • Oh, let me try that then... – John Dvorak Mar 31 at 11:24
  • RN I run your script + Olivia's script + mine at once, and I still get a refresh (triggered by my script). – John Dvorak Mar 31 at 11:25
  • @Olivia: what is supposed to happen when I click the "here you go" link? It shows the script, and the annoying "joke" still appears on every site. – Martin Argerami Mar 31 at 12:01
  • @MartinArgerami you need a userscript manager for any of the userscripts. if it just renders the script, that means you don't have one. If you're on desktop, there's several options depending on the browser. If you're mobile, you'll need Firefox (Chrome doesn't support plugins, not sure about Opera). There's several different ones, but one you can use is TamperMonkey. If you have one, it should prompt an install menu - the lack of one suggests you don't have one. – Olivia Mar 31 at 12:04
  • @Olivia: thanks. It's still not working. When I managed to pass the warnings and avoidances and finally see the script in Tampermonkey, it shows an error ("$ is not defined") due to jQuery not being available to the script. Most obvious solutions to this error (trying to make jQuery loaded by the script) failed for me. At this stage, too much time on this stupid issue. I'm off Stack Exchange for the day; stupid annoying "joke". Anyway, thanks for helping. – Martin Argerami Mar 31 at 15:48
  • @MartinArgerami jQuery should be available, unless it's somehow blocked. If you can't unblock it, there's also a jQuery-less solution – Olivia Mar 31 at 16:32
6

I have been FGITW'd by a cookie edit already, but if for some reason you prefer a userscript solution, let me provide one.

// ==UserScript==
// @name         Novikov Self-consistency Enforcer
// @namespace    http://tampermonkey.net/
// @version      0.1
// @description  Disables time travel on SE (April Fools 2019)
// @author       John "Novikov" Dvorak
// @match        *://*.stackexchange.com/*
// @match        *://*.stackoverflow.com/*
// @match        *://*.superuser.com/*
// @match        *://*.serverfault.com/*
// @match        *://*.askubuntu.com/*
// @match        *://*.stackapps.com/*
// @match        *://*.mathoverflow.net/*
// @grant        none
// ==/UserScript==

(function() {
    'use strict';
    const tm = document.getElementsByClassName("js-time-machine-button")[0];
    if(tm && document.getElementById("tm-scroll")) tm.click();
})();

Upside: automagically applies to every site, no need to insert it everywhere manually.
Downside: causes a blink of 90's content and a page refresh for every page that has the theme on. Solution pending... The folks in the Tavern have promised that I won't need to develop this script any further.
Also, let me know if I've missed a domain

  • Don't look now, but you've also been FGITW'd by two different user-scripts that use the cookie-based approach. Your unicorn sparkle powers seem to be in need of a recharge. – Cody Gray Mar 31 at 11:03
  • @CodyGray Oh? I haven't seen those. I've only seen Sonic's cookie code, but it's not packaged in a userscript. – John Dvorak Mar 31 at 11:04
  • Ah, just saw Glorfindel's code - and it's already voted above mine. – John Dvorak Mar 31 at 11:05
  • Also Zoe, who beat him to the punch. – Cody Gray Mar 31 at 11:07
  • @CodyGray let me test Zoe's code, then I'll deprecate mine using the delete button... – John Dvorak Mar 31 at 11:08
28

Going back to the future sets a cookie named tm2019. Unfortunately it sets it only for a particular question path, but using the browser devtools you can change the path to / that causes it to effect the entire domain. You will have to do it on every SE site individually though - but you can also change the domain to .stackexchange.com to make it act like a wildcard.

Screenshot of Chrom* Devtools with Application->Cookies selected


This is just a quick workaround. I consider the behaviour a , too.

  • 2
    This sounds like a good answer, but could you elaborate a bit for those who aren't familiar with devtools? – Wai Ha Lee Mar 31 at 10:40
  • 2
    Confirmed - this works. Still needs to be done per-site, and doesn't work on mobile, but it's at least something – Olivia Mar 31 at 10:40
  • Found the cookie for meta but not for StackOverflow. – vivek_23 Mar 31 at 10:54
  • 1
    @vivek_23 You will have to visit a question, and have hit the Time Travel button once. – Bergi Mar 31 at 10:56
  • @Bergi Yes, I confirm that this works now. – vivek_23 Mar 31 at 11:03
  • how do you make the changes suggested? As per Sonic's answer? – QHarr Mar 31 at 11:09
  • 1
    @QHarr Double-click on the value, enter the new one. – Bergi Mar 31 at 11:31
  • @Bergi Thanks for that – QHarr Mar 31 at 12:54
  • 1
    @Olivia, to make it work for almost all sites also edit the "Domain" to .stackexchange.com (NB with leading dot). – Peter Taylor Apr 1 at 11:40
3

One way to bypass this is to use the mobile theme. To do that, click "mobile" in the footer and you'll see the questions like this:

Better or worse? Up to you to decide. :)

  • That is too...minimalistic for most purposes. – Sonic the Anonymous Hedgehog Mar 31 at 10:38
  • Also breaks several userscripts that're designed for the full/responsive theme :/ – Olivia Mar 31 at 10:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .