2

When posting a link to a site's homepage in chat, the link automatically oneboxes to the site's logo.

However, I discovered a couple of related bugs with it. First, the logo for beta sites has been modified so that the word "Beta" is now capitalized, rather than all-lowercase "beta". When I post a link to such a site in chat, the old logo featuring the word "beta" in all-lowercase and the old color is posted. This also applies to newer sites that were created after the changeover.

Additionally, when posting a link to a site that was redesigned, in some cases the old logo for that site is posted. For instance, the Android Enthusiasts site was massively redesigned, with a new color theme and new logo (some time before the responsive designs began rolling out). However, the link posted in chat still uses the old logo. I couldn't reproduce this for all sites, however; for Stack Overflow, the new five-bar solid color logo is posted, rather than the old six-bar gradient logo.

Is it possible that the onebox system can load the site's logo live, rather than from some really old cache that hasn't been updated in a long time (and may only be manually updated)? Also, why is the old lowercase "beta" logo posted even for newer sites created after the network-wide design changes, which included changing the site's logo to have the word "Beta" capitalized instead?

  • From what I understand, which is only a partial understanding... It's not a cache. It's just a separate set of artwork that has to be manually changed. The artwork is designed to be used as part of the chat room... and the Android chat room styling is still green, so the logo is still green... and SO's logo changed a long time ago. The other ones that aren't updated are ones that changed relatively recently as part of the unified themes change... It's not so much a bug... but I don't know what to call it. – Catija Apr 5 at 22:01
  • @Catija The fact that new beta sites created after the design change show an old logo means it's a bug. Those sites never had the logos that the chat system oneboxes them as having. – Sonic the Anonymous WizHog Apr 5 at 22:23
  • No. It just means that we're still using the same tool when we create the logos. Also, beta site. There's only one that's been created since the site redesign. – Catija Apr 5 at 22:27

You must log in to answer this question.

Browse other questions tagged .