I'm trying to move a conversation to chat on a site I moderate. When I click the big button from the flag dialog, I get this:

enter image description here

It links to a chatroom that is most definitely empty.

I have also tried selecting the Mod > Move comments to chat button. This just reloads the page without deleting/moving any comments or posting the link to the chatroom.

I didn't post any links to the chatroom or post in question since I didn't want to attract too much attention to a random post. If an employee needs these links in order to hunt the bug down, I'd be happy to provide them.

2 Answers 2


I merged a chat PR earlier that added a couple new checks on room properties when creating a new message. And apparently a room can be null at that point. How? Why? Nobody knows, but null reference exceptions can be quite cruel.

The checks have been corrected and comments can be moved once again. If you're running into an issue with a specific post and are unable to move comments after this fix, please comment on this answer with the link of the post and I'll see what's what.

  • Thanks for the quick fix! I am still having trouble with the particular post: codegolf.stackexchange.com/a/182927/31716 And the chatroom is: chat.stackexchange.com/rooms/92322
    – DJMcMayhem
    Commented Apr 11, 2019 at 22:05
  • @DJMcMayhem Turns out that deleting the existing room unblocks that. I moved the comments and removed them from the post. Thanks for your patience!
    – Adam Lear StaffMod
    Commented Apr 11, 2019 at 22:39
  • It seems like this problem is back... Although this time the comments were moved into chat, they were not also deleted, and the comment linking to the chat room was not posted (nor was the auto flag cleared). Example post: codegolf.stackexchange.com/q/183600/31716
    – DJMcMayhem
    Commented Apr 23, 2019 at 21:56
  • @DJMcMayhem Good news! It's a different problem. :P Looks like the API requests to chat timed out, so while the whole thing partially succeeded, the site didn't know about it.
    – Adam Lear StaffMod
    Commented Apr 23, 2019 at 22:01

This definitely looks like a bug. I'll provide some more detail from my end. When I tried it (moving comments to chat using Mod > Move comments to chat) on a random post on Quantum Computing SE, I got this:

enter image description here

Notice the "Moving all comments to chat failed" pop-up. Like in your case, an empty chat room was created. When I tried it a second time, the page simply got refreshed.

  • 1
    Oh wow, I feel really dumb now. Yes, that's a huge detail that I left out. When I first tried it, I experienced the exact same thing as you. I just forgot to mention it since I couldn't recreate it.
    – DJMcMayhem
    Commented Apr 11, 2019 at 19:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .