10

On my profile page, if I click on any of the last three tabs -- All actions, Responses, or Votes -- I get an error page. All the other tabs work fine. I think this is new within the last 12 hours or so.

I tested on several sites (Meta, Worldbuilding, Mi Yodeya, Community Building). At first I thought the problem was that "private" tabs were broken (you can't see other people's responses or votes), but actions are public so it's not that.

Odd exception: on English Language & Usage, All actions results in an error but Responses and Votes work for me. Other users (see comments) report different sites that do/don't work for them, so it's not a site-specific problem. I can't identify anything that's different for me among the sites I tried. (It's not moderator versus not; I'm not a moderator on Community Building or English.)

  • For me on SFF, All Actions work, Responses and Votes don't. On Meta, only Responses doesn't work. On Movies and Lit, everything works fine... – Jenayah May 20 at 23:18
  • @Jenayah oh interesting, so it's not even per-site, if Meta works for you. I just discovered the inverse of what you report on EL&U -- actions fail, responses and votes work. – Monica Cellio May 20 at 23:20
  • It might even not be the sites (per se) at fault, apparently it works for someone else on SFF (see Alex's reply in chat) – Jenayah May 20 at 23:21
  • Everything works like a charm on mobile. FWIW, on computer I was on Windows 7, and one of the latest versions of Firefox (don't remember the number...). – Jenayah May 20 at 23:41
  • 1
    I get 500 on Responses and Votes here, and also on All actions on IPS Meta. – Sonic the Bracketed Hedgehog May 20 at 23:48
  • I get errors on your profile and GP's on some sites, OTOH other Sites such as SciFi and Quantum Computing work fine. – Rob May 21 at 0:00
  • Error message for me when I switch to desktop on the votes page. – Stormblessed May 21 at 0:32
  • I dropped this in the dev chatroom for someone to hopefully take a look at. – Taryn May 21 at 0:41
  • Also reported on Interpersonal Skills Meta. – Alex May 21 at 0:46
  • Similar problem for me on math.SE (all actions, Responses,Votes,...). – achille hui May 21 at 0:59
12

It depends on a certain timeline item type rendering a date block which had an errant translation in there. I've manually corrected the bad entry for now and we'll look at how to guard against it happening later - it shouldn't be allowed to happen but here we are so we'll look at improving that.

For the curious, it was ultimately calling .Day instead of .Days on a TimeSpan element in .NET with our generated code...and TimeSpan doesn't have a .Day so...kaboom. We'll think on how to validate this case that got through.

A fix is being deployed now, it should be out to all servers in about a minute.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .