This is a daily occurrence as I use StackExchange. Hit "Share..." Get the popup box, then struggle to select the entire URL.

enter image description here

While there may be iOS issues here, the point is the share textbox is intentionally too small to fit the URL.

And SE URLs are reasonably tinyfied, and of known size, which makes this undersizing rather senseless. It's like gating to exclude or frustrate mobile devices.

Here in iOS 9, you can drag the text box to the right, and it will even select invisible characters where they would be if the box were larger... Sometimes that works, but if you go 1px too far, it closes the selection area entirely and you must start over.

For my most copied URLs, I have taken to memorizing the last 3 digits of the URL and typing it in by hand.

  • 4
    I've not had issues clicking in the box, choosing "select all" and then "copy". Do you not get that "select all" option? Worth noting, that box is exactly the width of my iPhone, so making it any bigger would be problematic.
    – Catija
    Jun 9, 2019 at 18:11
  • As you can see, "select all" is simply not offered. It is not in the list above, nor is it in the icon tray. I have seen it, but I rarely see it. 95% of the time it is exactly this. Jun 9, 2019 at 18:13
  • 1
    It won't appear if you've selected some of the content. You have to just have the cursor in the box. Regardless, having a "copy" button (if that works in iOS) as part of the modal is probably the better/easier solution.
    – Catija
    Jun 9, 2019 at 18:13
  • Yeah, I often place the cursor in the box. I get the cursor in the box, tray icons of undo, redo and paste.. And no "above box" at all. I know the Select Select-all Copy "above box" of which you speak, it is just very, very shy. Jun 9, 2019 at 18:16

4 Answers 4


I agree that this should be widened - the URLs are not excessively long, we should be able to show the whole thing.

There's a more subtle problem with this, BTW: it obscures the fact that your user ID is on the end of that URL. I know a fairly experienced moderator who got tripped up by that recently!

This probably worked just fine in the old days when post IDs, user IDs, and textbox padding were all smaller.

  • Is removing the user id there not the easiest way to fix this particular aspect of the issue? I've made that mistake myself and copied a link that identified my SE account in a context where I don't want to reveal it. This would break the badges that rely on this information, but I don't think they're worth the trouble anyway. Jun 10, 2019 at 16:17
  • 3
    Well... That might be worth doing, but there's no way that retiring three badges is easier than increasing a width.
    – Shog9
    Jun 10, 2019 at 16:36
  • 1
    It's not the easier fix, but a more complete and reliable one for the information leak aspect. Removing the user id was status-declined by Jeff around 8 years ago, I was mostly wondering if it's worth bringing it up again. Jun 10, 2019 at 16:46


The URL is now auto-selected when you open the Share box. You can either hit Ctrl+C (or similar) or use the "Copy link" button to copy the URL.

On desktop/laptop:

enter image description here

On mobile (after pressing "Copy link"):

enter image description here


I would suggest an alternative: What about a "copy" button that does the copying job automatically? It'd be even more convenient for both desktop and mobile users.

  • I hate how it’s a free form text area! On desktop I often overwrite the entire thing by accidentally pressing space...
    – Laurel
    Jun 10, 2019 at 1:00
  • 1
    @Laurel On desktop I just right-click the "share" text and click "copy link", without even letting the text form show up. Jun 10, 2019 at 3:38

We've made a few changes to the Share dialog box since this request was made. There is now a "Copy link" option, and the link is auto-highlighted as well. As such, I've updated the status to .

  • 3
    Hello! FYI, @ mentions don't work in answers, so to ping Harper, you'd need to leave a comment on the question. IIRC, editing it to status-completed also pings the OP. Also, you need to do [tag:status-completed] not just [status-completed] in your answer for it to render correctly as a tag. Welcome to Meta, though!
    – cocomac
    May 18, 2022 at 16:42
  • 2
    Thank you @cocomac! Will remember to format the tag properly for next time.
    – tanj92 Staff
    May 18, 2022 at 16:49
  • Is it possible that change made the Share button disappear completely (on Safari 14, other browsers still have it for me)? May 19, 2022 at 11:18
  • @LаngLаngС Do you have any screenshots you can provide? Or a link to the question where the Share button is missing?
    – tanj92 Staff
    May 19, 2022 at 17:54
  • I have: imgur.com/yyZh2Ew Note: this is for me, when logged in, on Safari, since a few days I noticed (using the feature sporadically), on every post (there are no more share buttons at all), yet, a quick check in other browsers shows it should be there and is in them, just not my main SE browser… May 19, 2022 at 18:52
  • Thank you for the screenshot! I will check on my end to see if I can reproduce this issue. Are you experiencing this issue on Safari for a few other SE sites? I want to understand if it's specific to Safari and on a particular SE site (MSE in this instance) or if it affects others too.
    – tanj92 Staff
    May 19, 2022 at 20:27
  • It happens only in Safari 14 (Firefox, Chrome, Orion, Brave, Vivaldi… all 'clean'), even with all (blocking) extensions made sure as off/disabled, whether logged in or not; but on all SE sites I tried: this one, +Skeptics, History, Askubuntu. May 19, 2022 at 21:26
  • 1
    Got it, thank you for the information @LаngLаngС. It might be specific to that version of Safari. On my end, I am on version 15.4 and I have the Share option available: i.imgur.com/djWg165.png. I can go ahead and create a bug ticket for now.
    – tanj92 Staff
    May 19, 2022 at 21:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .