14

I have created a custom filter in https://stackexchange.com/filters and specified that I would like to get email updates:

Enter image description here

However, I never got a confirmation mail nor any notifications based on my filter.

I tried the "resent confirmation mail" button on the right hand sidebar:

Enter image description here

But again nothing happens.

The mail address should be fine

  • I used it for all kinds of notifications from Stack Exchange. For example the rep recalculation email arrived just fine on this address.

  • I retyped it several times to make sure there really isn't any typo

  • I double checked that it did not end up in the spam filter

  • I don't think it is a problem with my particular email provider, users with other mail providers seem to have the same problem, see Not receiving email confirmation on My filtered tags


This is possibly related to Tag subscription email not being delivered (2018–2019 edition), but this claims to be "status complete".


EDIT:

Although the "status-completed" tag was added, the problem still persists

EDIT 2:

As of Feb 2020, it finally works

  • SE sends email from a few different domains. Did you check your spam trap? – Monica Cellio Jun 30 '19 at 4:06
  • @MonicaCellio I checked in spam filter, no mail from stackexchange there – samcarter_is_at_topanswers.xyz Jun 30 '19 at 12:07
  • 3
    It's possible that we fixed this for only the email actually being sent with questions in it but not the confirmation email at the beginning of the process. Someone will have to look. Other reports I've found are only complaining about the confirmation email as well. – animuson Oct 10 '19 at 15:03
  • @animuson Thanks for the update! – samcarter_is_at_topanswers.xyz Oct 10 '19 at 15:25
  • 2
    @animuson What's the status of this? – DanielSank Oct 30 '19 at 20:34
  • similar problem, however with an existing filter instead of a new one: meta.stackexchange.com/questions/337217/… – samcarter_is_at_topanswers.xyz Oct 30 '19 at 21:50
  • Update: works as of Feb 2020. Thanks a lot for finally fixing! – samcarter_is_at_topanswers.xyz Feb 5 at 0:12
5

The issue here wasn't related to previous email problems. It was actually even more ridiculous. We were running a check for whether to add BCC headers to the email, skipping it if the value was null. Turns out, the default value is an empty string, not null, so it was trying to add an empty BCC header to this particular email, and the mail system was yelling about it and refusing to cooperate.

This has now been fixed to correctly check for an empty value when skipping that header, and confirmation emails should go out when requested now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .