20

When writing an answer on a site where you don't have an account or are not logged in, below the answer entry textbox are options to create an account or continue as guest by providing a nickname and email.

I had written an answer of several paragraphs on a network site, clicked "Sign up with Google" (resulting in association to my existing network-wide profile) but after doing so instead of showing my answer to be posted, only the first five or six words were retained. I know that I had no account on this site previously because I just received the association bonus... I cannot tell whether the bug also affects totally new users or those with accounts but who are not logged in.

This is a very unwelcoming user experience. Please fix it.

If the intended workflow is to click "Post Answer" first and associate the account afterwards, then the sign up options should not be shown until the answer is posted, and certainly not above the Post Answer button.

This problem also occurs if you already have an account on the site, and click 'sign up with google' (which allows you to successfully log in).

  • I found out that this also happens if you already have an account, so people used to logging in by clicking 'sign up with google' willget hit. This means the problem is likely occurring much more than expected as it is not only about first time users and the google button is quite inviting and does not provide a warning. – Dennis Jaheruddin 2 days ago
2

How I ran into it

After completing my post, I clicked 'sign in' > 'sign in with google' to leverage my network account that has Google login capability.

As soon as the login+account was created, I was shown my post, and to my horror only the first 2 lines remained (out of 15 or so).

I am using the most up-to-date version of Chrome on a Mac. I believe this also happened perhaps a year ago, so I suspect there is either a missing autosave when clicking the button that leaves the page, or an issue that not necessarily the latest version is displayed.

The workaround that worked for me

In a moment of clarity I went back 5x to the previous page (directly after seeing that I only had 2 lines left) and found the full text.


However, there can be only one conclusion, as it is clearly not a single incident:

This should be fixed

| improve this answer | |
0

A workaround would be to open the Sign Up page in a new tab or window by right-clicking it.

| improve this answer | |
  • 5
    This is useless; you already can click "post answer" without clicking sign up first. But if you don't know that the "Sign Up" button will erase your work, you have no way to know to do it in a new tab. – Ben Voigt Apr 28 at 22:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .