0

I'm having trouble adding two image links as images to an answer of mine. You can track my edits to see the attempt.

I can see images at edit preview but when I save it, the images are not displayed properly. Only the alt text is displayed.

What is wrong with these images?

2
  • Works for me. I can see them.
    – alex
    Commented Dec 16, 2009 at 10:19
  • @I hate haikus : because images are added by <img> tags.
    – Canavar
    Commented Dec 16, 2009 at 10:23

2 Answers 2

2

The problem lies with the fact that there are underscores in the full image path.

Writing them up in the old HTML code (<img>) fixes it nicely.

There are ever so slight differences between the rendered preview of Markdown using JavaScript and the baked HTML version. The underscore notoriously being that little trigger.

Compare the filename versions when writing them in:

Markdown - ![ ]

 42356759v1%5F350x350%5FFront%5FColor-AshGrey.jpg

HTML - <img />

 42356759v1_350x350_Front_Color-AshGrey.jpg

Using HTML will force it to keep, otherwise Markdown will convert the underscores (_) and play up.

3
  • No, underscores are no problem here. The only thing preventing from showing it for me was my Ad-Blocker. Commented Dec 16, 2009 at 10:17
  • 2
    specifically, it is mixing of dash and underscore in the same URL. Rare, but Markdown REALLY doesn't like that. Commented Dec 16, 2009 at 10:20
  • @John Smithers : But I can see the images now, with the <img> tags. And I do not block images. This solution seems to work. Thanks. But really strange, What is the purpose of this featue ?
    – Canavar
    Commented Dec 16, 2009 at 10:21
1

Disable Ad-Blocker!

2
  • Never!!!!!!!!!!
    – alex
    Commented Dec 16, 2009 at 10:19
  • Haiku hater, your use of punctuation marks is disgusting. I would downvote you, if I could. Commented Dec 16, 2009 at 12:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .