13

When attempting to annotate a user's account, I found that I was unable to submit my note as the button was disabled, and the text showing remaining characters allowed was not visible.

After a bit of investigation, and help from a friendly CM, we discovered that this is because two popups are generated - and the working popup was hidden behind. This only occurs when attempting to annotate via the mod dashboard tab. Profile and activity both work. This is confirmed to be broken on Stack Overflow and Code Review.

enter image description here

6
  • 1
    Somewhat reproduced here on Meta.SE. I don't see two copies of the pop-up, but the one I see is like the broken one you see, and the main menu (the one with annotate as an option) is still here under it. Update: oh, that's using the "mod" menu on the "mod dashboard" tab. If instead I click directly on the "annotate" link, I see what you do. Commented Aug 1, 2019 at 3:26
  • @MonicaCellio Hmm, not sure if I'm following... what do you mean by having the main menu under it, if you don't have two copies? If you mean that you don't see them expanded/side-by-side - that's just because I moved them for the screenshot :)
    – ert
    Commented Aug 1, 2019 at 3:34
  • 2
    Both the "annotate" button in the left menu and in the mod menu produce this effect. They're stacked so it's easy to miss that there's two of them but you can move them around by grabbing the top of the modal.
    – Catija
    Commented Aug 1, 2019 at 3:37
  • 2
    I moved them too. :-) If I go to that page and click the "mod" menu link and from there click "annotate", then the bottom layer is that menu and the upper layer is the broken annotation UI. If, on the other hand, I click on the "annotate" link on the left instead of the menu, I get the two versions of the annotation UI like you showed. Commented Aug 1, 2019 at 3:37
  • @MonicaCellio Oh, yes, that's just because I clicked the annotate button on each popup
    – ert
    Commented Aug 1, 2019 at 3:39
  • 1
    Screen shot: i.sstatic.net/XGlH7.png Commented Aug 1, 2019 at 3:40

1 Answer 1

7

This will be fixed in the next build.

I've been doing some foundational work on this as part of an accessibility refresh on the menu. As part of that, I combined the logic for the "Mod" button and the "mod, but select a tab" buttons. Unfortunately, I left the initialization code in both places, so each event got wired twice.

The following dialog behaviors probably accounted for me missing this in tests:

  • We don't disable the button once we've enabled it by selecting something else.
  • Submitting is a page nav so you don't see the lower dialog.
  • Outside clicks dismiss both dialogs.
  • The simpler actions were working as expected.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .