22

Note: This announcement is directed at moderators as it is about moderator-only tools.

The post and user moderator menus are getting a design, accessibility, and UX refresh.

Before

enter image description here

After

enter image description here

There are the key highlights:

  1. It's prettier and the frontend JavaScript has been completely reworked using a controller and state-driven design.

  2. It's accessible. Standard tab-based navigation works as well as (at least) macOS VoiceOver.

  3. It's mobile responsive and works in the mobile question view.

  4. Many of the non-destructive methods (those that don't spew out a bunch of text) no longer navigate the page and instead refresh the content inline. This should be a huge improvement when using the mod menu from inside the flag dashboard.

When is it rolling out?

It's rolling out to SO, MSO, and MSE today. Based on the feedback collected over the weekend, this will likely roll out to English-language sites early next week followed by international sites after the translators have had a chance to translate.

Where should I file bugs?

For now, it'll be best to file bugs here so I get pinged about it. Long term, they should be new questions tagged .

If you're going to write a bug about the janky movement on expand/collapse of items, that's already being worked on, I just didn't want to delay getting feedback.

What new strings were added?

A list of recently added strings are at: https://docs.google.com/spreadsheets/d/1obD3P1MI1jS5fhDn2e6n8-OhdnP8hH6GRVacGvFhdNU/edit?usp=sharing

There are a few more for success and error messages from earlier commits that are going to be harder to track down.

  • 1
    Am I correct in assuming that add wiki/remove wiki is a toggle, rather than both being present but one grayed out like in your first screenshot? (That would be consistent with the other toggles.) – Monica Cellio Aug 16 at 23:26
  • 1
    @MonicaCellio Yeah, only one should be present at a time. That first screenshot was with the old UI and no user scripts. – Brian Nickel Aug 16 at 23:28
  • 1
    Oh, is the reason I only see one wiki option (on sites with the old UI) because some userscript fixes it? TIL. :-) – Monica Cellio Aug 16 at 23:31
  • 2
    So, it's slightly complex @Monica (as is everything when it comes to CW, amirite?): the "convert to wiki" disappears when the post is already CW. The "remove wiki" option appears only when the post is already CW... OR, in the case of questions, if any answers are CW. So it's entirely possible for both to appear together, though normally it will appear to be a toggle. – Shog9 Aug 17 at 1:47
7

Until yesterday, I was able to destroy users with the usual trick of MM4TabAEnter.

However, this has stopped working today. Using ? still shows that we can bring up the mod menu, but it doesn't seem to be working.

To make sure that I am not seeing things, or my keyboard is not broken, I tried with a new keyboard. Also I tried using I for inbox and GM to visit meta, both of which worked flawlessly.

  • This is fixed. The new moderator menu wasn't exposed to keyboard shortcuts. The new pattern will be M-M-4-A-Enter, as 4 will keep the radio button focused and not shift it to the input. – Brian Nickel Aug 27 at 20:51
7

enter image description here

I am not able to select "Submit" here. The lookup tool to find potential socks has been broken since a while now, and I've been adding a link to the sock in the description and deleting them as a sock. However, I am not able to delete them as socks now as the "Submit" button is disabled.

  • I'll remove the requirement. Can you expand on what you mean by it being broken? Is there a post you can point me to? – Brian Nickel Aug 19 at 19:15
  • @BrianNickel, thanks so much for that. The "this user is a sock puppet of" popup in the mod menu does not pick up socks whose votes were invalidated by the system. (There are other issues as well, but given that it is related to voting, I don't think there's any public posts) – Bhargav Rao Aug 20 at 0:03
  • This is fixed. Now the submit button is enabled if either a potential sock is selected or details are filled out. – Brian Nickel Aug 27 at 20:55
  • Thanks for all the effort, @BrianNickel. I guess it isnow time to find out more bugs in the code. – Bhargav Rao Aug 28 at 1:47
5

Clicking destroy from the mod dashboard brings up the UI with the destroy option disabled as they have more than 500 rep although that's not the case... I imagine it's probably along the same lines as what Bhargav's reported but thought I'd add it just in case...

example screenshot

Also the "To contact the community team about your own account..." is also a little suspicious... is it thinking I'm trying to destroy myself? (Kind of worried that while trying to clear up spam/troll accounts, mods might inadvertently end up queuing themselves for deletion)

  • This is fixed. It was indeed showing the form for the current user (you) and not the user on the page. – Brian Nickel Aug 27 at 20:56
  • Does this mean that if Jon had been able to click submit he would have destroyed his own account ?!?!? – rene Aug 27 at 21:02
  • 2
    @rene Is that concern or disappointment my flowery friend :) – Jon Clements Aug 28 at 7:24
2

Using Enter key to submit the different forms are no longer working. This includes while annotating the accounts.

  • I'm fixing the use of the enter key, but wrt annotating, pressing enter wouldn't submit in the old design and just trigger a new line. You would still have to tab twice to get to the next form element (which happened to be submit). – Brian Nickel Aug 19 at 18:39
  • Ah, cool, thanks. I do remember pressing enter on annotate, perhaps I'm remembering it wrong. Anyway, it was broken on the other items as well, so glad that it was fixed. Thanks – Bhargav Rao Aug 20 at 0:05
  • So I tried annotating the old way, turns out we need to press tab once and it auto selects the "submit" button. ... can this be done in the new one also? thanks so much! – Bhargav Rao Aug 20 at 4:53
  • This is fixed. Now Enter submits the form if you're not in a textarea and it meets whatever criteria enable the submit button. – Brian Nickel Aug 27 at 20:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .