10

I'm experiencing a strange bug. If I add a ping (@user) in my chat message, or reply to a specific message, then the message times out:

enter image description here

Ordinary messages go through just fine.

2
  • 3
    I also had this bug at the same time in the same room. However, it seems to have cleared up already.
    – Veskah
    Commented Sep 19, 2019 at 15:32
  • Ohh it's bug. I think it's my ISP fault.
    – 4b0
    Commented Sep 20, 2019 at 11:39

1 Answer 1

11

We just deployed some fixes to chat that necessitated some database changes. I thought that the builds were configured to run migrations automatically but, of course, I didn't confirm that. Chat's codebase is one of the oldest around here and it hasn't had a lot of changes, in particular any changes at all to the database in recent times. So I hit build, the code expected a new column to be there and then we started throwing an exceptions everytime we tried to read from the Users table.

I've run the migrations by hand and I'm working on fixing the production build to run migrations by itself like it should.

Apologies for the inconvenience!

2
  • 5
    Just curious, what kind of fixes were you deploying?
    – Mithical
    Commented Sep 19, 2019 at 15:47
  • Fixes were for employee-only rooms; notably re-instating full name and out of office notifications. Nothing user-facing I’m afraid...
    – Dean Ward
    Commented Sep 22, 2019 at 16:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .