4

One of our users recently tried to access the StackExchange chat through chat.crypto.stackexchange.com which depending on a few things will either yield a domain miss-match certificate error or will yield you a page showing you an error:

Server Error in '/' Application.

Runtime Error

Description: An exception occurred while processing your request. Additionally, another exception occurred while executing the custom error page for the first exception. The request has been terminated.

Note that for any other unmapped site, like potato.crypto.stackexchange.com or potato.meta.stackexchange.com you actually get an error that says "couldn't find this Q&A site" so this is apparently a bug in the chat server software (or at least an inconsistency).

As this issue also covers other sites like chat.security.stackexchange.com this is posted here on Meta.SE.

While I see why this is a low-priority issue, a fix to this would be as simple as un-mapping the DNS for chat.site.stackexchange.com I suppose?

  • Is that linked somewhere from the UI? Or did that user just tried to type it in the addressbar and hope for the best? – rene Oct 4 at 9:56
  • I think there is at least a wildcard catch and rewrite there to redirect stale meta.crypto.stackexchange.com domains. – rene Oct 4 at 9:58
  • @rene It would appear the user typed it in manually and hoped for the best. – SEJPM Oct 4 at 10:04
  • 2
    I would hardly qualify that as a bug but YMMV. – rene Oct 4 at 10:17
  • @rene dig \*.crypto.stackexchange.com. gets answers, so confirmed. – iBug says Reinstate Monica Oct 4 at 10:23
  • @iBug thanks, I'm rather unqualified when it comes to DNS and I refuse to learn how nslookup works as I only have a windows box at my disposal atm. – rene Oct 4 at 10:26

You must log in to answer this question.

Browse other questions tagged .