9

Steps to reproduce:

  1. Open https://stackexchange.com/questions in Guest/Incognito mode or with cookies disabled. This will have 30 questions per page by default.
  2. Click the "50 items per page" link and as expected, you'll see questions 1-50 with page size of 50.
  3. Go the the second page and see the bug: you're in the second page of 30 items per page, i.e. you'll see questions 31-60 instead 51-100 as expected.

    https://stackexchange.com/questions?pagesize=50

It is very annoying. Please fix it.

My user-agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:70.0) Gecko/20100101 Firefox/70.0

There are no plugins installed affecting the site. It happens both when logged in or not.

The mechanism used to work before, but some weeks/months ago it stopped, enough to bother me to post here :)

Here are all modified "privacy" settings from about:support page:

privacy.clearOnShutdown.offlineApps true
privacy.clearOnShutdown.openWindows true
privacy.clearOnShutdown.siteSettings    true
privacy.cpd.offlineApps true
privacy.cpd.openWindows true
privacy.cpd.passwords   true
privacy.cpd.siteSettings    true
privacy.donottrackheader.enabled    true
privacy.history.custom  true
privacy.item.cookies    true
privacy.sanitize.migrateClearSavedPwdsOnExit    true
privacy.sanitize.migrateFx3Prefs    true
privacy.sanitize.pending    [{"id":"shutdown","itemsToClear":["cache","cookies","offlineApps","history","formdata","downloads","sessions","siteSetti
privacy.sanitize.sanitizeInProgress ["cache","cookies","offlineApps","history","formdata","downloads","sessions","siteSettings","openWindows"]
privacy.sanitize.sanitizeOnShutdown true
privacy.sanitize.timeSpan   0
privacy.trackingprotection.enabled  true
privacy.trackingprotection.introCount   20
15
  • 2
    I can't reproduce this. Right now, if I go to the HNQ, page two, I get 50 results, the second half of the 100-item list. Can you give some system information and check whether you have any add-ons or scripts that may be messing this up? Are you logged in when viewing this page? The system remembers your choice, so if I choose 50 today, it will be 50 forever... is it possible that the cookies for this are getting deleted? Also, random statement but... 25 isn't an option. The choices are 15, 30 and 50. :)
    – Catija StaffMod
    Nov 21 '19 at 22:09
  • 1
    @Catija Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:70.0) Gecko/20100101 Firefox/70.0
    – Marlon
    Nov 21 '19 at 23:56
  • added some steps to reproduce, thanks!
    – Marlon
    Nov 22 '19 at 0:02
  • I have the same configuration as you but I still can't reproduce it, even with the detailed steps.
    – Glorfindel Mod
    Nov 22 '19 at 6:06
  • Do you have add-ons or options enabled blocking tracking and/or cookies?
    – Mast
    Nov 22 '19 at 7:12
  • The pagesize is removed from the link on the next page, but the setting is still there.
    – Mast
    Nov 22 '19 at 7:13
  • nothing addon-ish, but definitely have a lot of privacy stuff enabled. but a website should still work and not force me to disable my privacy! :P if you explain the mechanism how the settings are stored i could try switching off some of the privacy settings and see if it fixes it, but really it would be nice if the page just kept the parameter. Or let me see all pages at once, then I don't care about the pagesize anymore!!! :)
    – Marlon
    Nov 25 '19 at 23:34
  • privacy settings included in question.
    – Marlon
    Nov 25 '19 at 23:37
  • @Catija see my edit. It's something with cookies, as the site can't preserve the last selected page size. Nov 26 '19 at 7:55
  • I was able to repro on FF on MAC
    – Luuklag
    Nov 26 '19 at 8:20
  • @Luuklag yeah, or maybe it's a mac thing. glad someone else is seeing it, too!
    – Marlon
    Nov 26 '19 at 23:58
  • @Catija any update on the problem? still getting it.
    – Marlon
    Dec 17 '19 at 0:22
  • 1
    No updates. It’s in a queue of minor bugs but until it’s triaged it’s unlikely to be updated.
    – Catija StaffMod
    Dec 17 '19 at 0:47
  • okay, thanks for the update!
    – Marlon
    Dec 17 '19 at 3:26
  • One of the devs here. Was able to reproduce this, but it seems only on FF. Putting this in our queue to address.
    – Jon Chan StaffMod
    May 1 '20 at 15:23
4

It looks like this was finally resolved at some point on all browsers (including FF where we had previously been able to reproduce it).


Even if you want
lists only incognito
page size now sticky

1

Suddenly started working fine, privacy settings are the same as aboe in my question.

Maybe it was a the new browser version, maybe someone fixed SE. Current browser:

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:74.0) Gecko/20100101 Firefox/74.0

Whoever fixed it, thank you!!!

0

This is not restricted to Stackexchange.com

Following similar steps I also reproduced this in a private tab on Stackoverflow.com. I changed the number of items from 15 to 30, went to the next page to be served 15 questions.

Running FF 68.2.0esr (64b) on macOS Mojave 10.14.6

Using Chrome on Android failed to reproduce this.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .